Testing wikisandbox.kde.org

Fragment of a discussion from User talk:Claus chr
Jump to: navigation, search

Hi Claus,

I fixed the first problem. This was caused by a missing JQuery plugin: https://github.com/cowboy/jquery-throttle-debounce/ 10 year old but still working ;)

I don't understand the second problem, I can see the links in my browser. Maybe this was fixed by fixing another bug or you mean other links.



11:40, 13 July 2019

Hi Carl

The problem still exists, but I was wrong in saying that it happens in certain cases; it seems to occur randomly. Sometimes, when I go to a translation page it will look like this:


While the page look like this I can't get to any translation unit whether it has been translated already or not. I have to reload the page to get this:


In and of itself this is not a big problem, but until you hit on the idea to reload the page it may make translators think that the translation system is broken.

The good thing is that a long standing problem with the translate system seems to have been solved. Pages that had been modified did not show up as modified in the translate system, but they do now!



09:43, 14 July 2019

I'm quite busy lately, sadly my finals are coming, but after the 25 July, I should get more times to fix it and update the other wikis.

13:46, 14 July 2019

Most of the problems mentioned in this thread have been solved! \o/

I have created a page for problems that we should look into.

10:45, 23 July 2019


I couldn't reproduce the bug with the registration. I created a new identity account and the registration to the wiki worked. Did you do something special during the registration?

For the translation bugs, I think this is a problem in the job queue. I think we are using the default settings, but MediaWiki has some recommendation (creating a cron job). I will discuss this with Ben.

08:18, 24 July 2019

The login problem is something I found on an old dodo list, it may have been solved a long time ago - I included it just in case. I'll remove it from the list. The e-mail settings problem also seems to be ancient history.

06:19, 25 July 2019

Yeah I'm now in vacation, so I started looking at the issues. Some are already solved.

The login problem is probably not solved (I didn't modify the phabricator extension), but the phabricator login will need to be replaced by a gitlab login anyway.

The list numbering problem is very strange, I have the same problem with Firefox but not with Chromium.

Is the Special:WhatLinksHere problem still here?

About the language in the search, it should be possible to filter with: https://www.mediawiki.org/wiki/Manual:Hooks/SpecialSearchResults but it will be difficult to get the user language and not having false positive.

12:37, 25 July 2019

The Special:WhatLinksHere problem still persists. It has been around for a very long time - possibly for as long as the translation system.

10:24, 26 July 2019

I think it's fixed now (I tested it 20 times and I didn't get this bug again). Let me know if the problem still appear.

Otherwise, I will publish my patch upstream ;)

20:32, 26 August 2019

\o/ Thanks a lot. I shall test it the next couple of days. I'll let you know if I encounter the problem again.

04:43, 27 August 2019