Archive:Http://userbase.kde.org/Akonadi 4.4/Troubleshooting/rue

Revision as of 10:14, 27 August 2010 by Gazeb (talk | contribs) (Created page with ''''Kontact''' працює, але вы видите окно з такым повідомлїнём:')
Jump to: navigation, search

Вступ

Тота сторінка є присвячена головно одстранёваню проблемів, звязаных з Akonadi, кідьже на початочных кроках переходу до новой сістемы все взникають проблемы. Про велё хоснователїв перша стріча з роботов Akonadi буде в KDE 4.4, і велё з них буде змятено роботов сістемы. Короткый опис призначчня Akonadi можете найти в тым записї ґлосарія. Окрем того, в тексті статї найдете іншы хосновны одказы. По здоланю прикрых проблемів з Akonadi ся тота сістема стане силнов хыжов хосновательнов многыма проґрамами.

О штруктурї дат сістемы

Звычайно можете хосновати Kontact на ряджіня вшыткых вашых адресных книг, але як хоснуєте сістему резервного копірованя дат, треба вам знати, де вашы дата суть і як што з нима маніпулує. В тім вам поможе сторінка Akonadi_and_AddressBook.

Тіпы про одстранёваня проблемів

  • Кідь репортуєте проблемы із сервером Akonadi, все додавайте репорты з автоматічного самотестованя сістемы. Тоты дата можете обтримати за помочі модулу Центра ряджіня, до котрого ся можете дістати за помочі команду:
kcmshell4 kcm_akonadi
  • Штарт сервера Akonadi ручнї за помочі командового рядка вам може дати додаткову хосновну інформацію. Тото можете зробити спущінём команду на конзолї:
akonadictl start

Similarly, with this command the Akonadi server can be stopped again:

akonadictl stop

This command gives more useful information:

akonadictl status

Тіповы проблемы

Не штартує Kontact — і при тім проґрам ніч не повідомлять

Кідь Kontact не штартує і не повідомлять о хыбах, перевірте, ці є зпущене Akonadi. Akonadi має быти зпущене на запит. Кідь ся вам не доведе зпустити сервер по зпущіню Kontact, кідь ресурсы вашой системы были перетворены (найправдоподобнїше, ресурсы KAddressBook). Про зпущіня сервера хоснуйте піктоґрам сістемовой лишты Akonadi.

Kontact ся не зпущать, інша причіна

Kontact ся ставать праценездатным по актуалізації. Кідь ся тото стало попробуйте спустити KMail, KOrganizer або даяку дялшу аплікацію з KRunner (або Konsole). Шанца є высока, же будуть працовати як самостатна аплікація, кым найдете што плане ся стало. Тото ся тыкать головно верзії 4.4.0.

Адресарь ненайдженый: «/Local»

Даякы люде репортовали хыбу, же Kontact ся не спустить. В скорых верзіах серії 4.4 была хыба, проґрам KMail глядав локалны дата пошты в ~/.local/share/Local, каталоґу, котрый не быв заповненый датами. Жебы сьте ся збавили того проблему не намагайте ся справити го ручнї. Заприйте окна KMail/Kontact, отворьте консолу Akonadi:

  • стисните комбінацію клавес Alt-F2
  • або хоснуйте команд "akonadiconsole" в konsole

Then remove the resource that it says is for local mail. You should now find that you can start Kontact or KMail, and that a new resource will be created, pointing to ~/.local/share/local-mail

В ~/.local/share/ ся зъявили якысь новы адресарї

Так має быти. Кідь ваша книга адрес была міґрована належным чіном, буде створеный новый ресурс в ~/.local/share/contacts/.

Што є /usr/bin/akonadi_maildir_resource і /usr/bin/akonadi_maildispatcher_agent?

Файл akonadi_maildir_resource ся створює автоматічно проґрамом akonadi_maildispatcher_agent. Тот проґрам ся все спущать нараз із сервером Akonadi, кідьже забезпечує базовы функціоналны можливости (наприклад, посыланя пошты), котры хоснують вшыткы поштовы проґрамы, котры суть заснованы (або будуть заснованы) на Akonadi. Также штарт тых двох проґрамів є нормалный став, хоснователь їх може іґноровати. Файл autogenerated akonadi_maildir_resource є сімволічным одказом, котрый вказує на ~/.local/share/local-mail/, конто вашых Локалных адресарїв, де суть вашы дата і повідомлїня електронічной пошты.

У тій верзії, KDE 4.4, поштовы дата ся не перетворяють.

Помічны проґрамы індексованя Nepomuk незапнуты

Kontact працює, але вы видите окно з такым повідомлїнём:

NepomukError.png

The most common reason for this notice is that Nepomuk is simply disabled in System Settings. Please try enabling it in System Settings under Advanced -> Desktop Search -> Basic Settings by checking "Nepomuk Semantik Desktop" and clicking "Apply".

If this does not help (or if the option was already checked when you got the error) and if you have previously been using prereleases of KDE SC 4.4, you may be affected by a change to the database layout (due to an upgrade of the Virtuoso database server from version 5 to version 6; production releases of KDE SC 4.4 are expected to be shipped with Virtuoso version 6). The following commands should get it working again:

qdbus org.kde.NepomukServer /nepomukserver org.kde.NepomukServer.quit

rm -r ~/.kde/share/apps/nepomuk rm -r ~/.kde4/share/apps/nepomuk

nepomukserver

Note that the above commands will not enable Nepomuk permanently if it isn't already enabled, you have to use System Settings for that.

A running Nepomuk is necessary to have a working Akonadi, and thus a working Kontact. However, you can disable the Strigi file indexer, which is not needed for Kontact. Strigi file indexing is used for desktop searching only, which is unrelated to Kontact. Just make sure Nepomuk itself is running correctly for Kontact.

In Kontact, Nepomuk is used for many different things, ranging from displaying upcoming birthdays, over handling free/busy lists to showing a contact photo in the message viewer. If Nepomuk is not running, several different things in Kontact will cease to work. The notice is there to warn you about the reduced functionality. Enabling Nepomuk as described above fixes the problem.

You can check if Nepomuk is correctly running by typing:

akonadictl status

I want to use my current Address Book and Organizer - Can I?

Yes. When you use the Akonadi Console to add a resource it allows you to choose as Standard Addressbook - point that to your std.vcf should work fine. Migration does not destroy your old addressbook. You can continue to use it, though you will lose any benefits that Akonadi can bring. Alternatively you can have both an Akonadi addressbook and your original one, for a time, if you feel safer that way.

I can't see any details in my Address Book

At the moment, the cause of this is not identified, but the cure is simple. Close Kontact, and start KAddressBook as a stand-alone application. After you close it you will be able to use it within Kontact. It seems that something is not being triggered when Kontact launches, and I expect this to be identified and fixed soon. This seems to mainly affect version 4.4.0.

My contacts don't show when I use the Select button in KMail

Check System Settings -> Advanced tab -> KDE Resources. Make sure that your Akonadi controlled address book(s) are listed there - add them if necessary. At the same time, it's a good idea to make your main Akonadi addressbook, usually called "Personal Contacts", is set to be the default. More details of how this can be found in here.

How do I get my Groupware addressbook back?

Two solutions: using the old framework or the new one.

Old framework: In akonadiconsole, add a "KDE Address Book (traditional)". The KDE Address Book means you can set up old kresources for Akonadi. In the configuration of "KDE Address Book (traditional)", you point it to an "IMAP over KMail" KResource and in KMail, the groupware options should be enabled. This should work for Kolab, eGroupware and similar addressbooks - you will need to check the options to make sure that the correct type is selected.

New framework (only tested with Kolab): In the Akonadi configuration module add an "IMAP E-Mail Server" resource, and set up your mail server name, username and password, then click Auto-Detect. Run this command to see it:

kcmshell4 kcm_akonadi

Then add a Kolab resource. The next step is to wait for the imap resource to synchronize, which can take quite a long time. The status will appear in the Akonadi configuration module. If nothing happens, try restarting akonadiserver. After some time the Kolab addressbook(s) should appear in KAddressBook.

You experience long delays when sending mail

This is accompanied by KMail freezing until the mail is actually dispatched.

A bug has been found in the way Nepomuk checks addresses, which can cause huge delays. This is fixed for SC 4.4.1. If you cannot get 4.4.1 yet, there is this work-around:

Close Kontact, or KMail and KAddressbook if you are running stand-alone apps. Disable Strigi in SystemSettings. Stop Nepomuk, delete the database and restart nepomukserver. The actual commands you need are (as user):

qdbus org.kde.NepomukServer /nepomukserver org.kde.NepomukServer.quit

rm -r ~/.kde/share/apps/nepomuk rm -r ~/.kde4/share/apps/nepomuk

nepomukserver

This will, of course, wipe out all the database, including any tags you've added. In theory, I understand that it's possible to do a more selective wipe of the database. If this matters to you you can find the instructions at this page

IMAP Resource always claims to be offline

Even though the system has an internet connection, the IMAP resource refuses to switch to online state.

This bug is caused by a misconfigured NetworkManager installation on your system. Check the output of

qdbus --system org.freedesktop.NetworkManager /org/freedesktop/NetworkManager org.freedesktop.NetworkManager.state

If it is '4' (Disconnected) but you can access the Internet, then your NetworkManager is indeed configured wrong. If it is '3' (Connected) the problem must be somewhere else. Under Debian this behavior can be caused by interfaces defined in /etc/network/interfaces, which are not controlled by NetworkManager. To fix this, simply remove the entries from /etc/network/interfaces and let NetworkManager handle them.

Some Technical Issues

Nepomuk

Starting with KDE 4.4, it is required that Nepomuk is running in order for Akonadi to work correctly. Akonadi will check this and display an error dialog on startup if this is not the case.

Nepomuk only works with the Virtuoso backend. You can check whether the Nepomuk is running with the correct backend by using the Akonadi self-test dialog, as described above.

Although Nepomuk is required to be running, you can still disable Strigi file indexing, which is usually the most resource-intensive part of the Nepomuk framework.

Apparmor

Some distributions using Apparmor have it set up in a way that prevents Akonadi from running its internal database server. This can result in a variety of fuzzy error messages, including but not limited to the following:

unknown error 255 when running akonadictl

"DB error: 'Could not open required defaults file: /home/$username/.local/share/akonadi/mysql.conf"

You can solve this by running the following command with root privileges then reload apparmor:

aa-complain mysqld

On Kubuntu this is:

sudo aa-complain mysqld
sudo /etc/init.d/apparmor reload

Note that you might be using Apparmor even if it does not show up in the process list.

Also note that some distributions ship an additional mysqld binary called mysqld-akonadi which has AppArmor set up correctly. If that's the case on your system and you see this problem nevertheless, there are two possible reasons:

  • Akonadi still uses mysqld instead of mysqld-akonadi. You can change that in Systemsettings -> Advanced -> Akonadi -> Server configuration.
  • AppArmor is not setup correctly for mysqld-akonadi either. Try running the "aa-complain" command noted above with mysqld-akonadi instead of mysqld.

---

You will also experience this problem if you are running an encrypted home directory using encryptfs combined with AppArmor as the Akonadi apparmor profile currently does not account for an ecrypted home (common with Ubuntu Jaunty users). Error messages with include:

  • dmesg produces:
ecryptfs_do_create: Failure to create dentry in lower fs; rc = [-13]
ecryptfs_create: Failed to create file inlower filesystem
  • Akonadi will list the following errors:
Akonadi server process not registered at D-Bus

The fix is to edit the following file "/etc/apparmor.d/usr.sbin.mysqld-akonadi". Below the line:

@{HOME}/.local/share/akonadi/** rwk,

Add a new line:

@{HOME}/.Private/** rwk,

Restart apparmor and restart akonadi.

Missing Prerequisite

To use Akonadi you need to have the following packages installed (names might differ depending on your distribution):

  • The MySQL server (called mysql on openSUSE)
  • The Qt4 MySQL plugin (called libqt4-sql-mysql on openSUSE)

If you compile Qt4 yourself, make sure to tell the configure script to build in MySQL support by passing it the following option:

-plugin-sql-mysql

If "configure" cannot locate the necessary MySQL client code (i.e, says "MySQL support cannot be enabled due to functionality tests") then ensure that the corresponding package is installed (typically called [lib]mysql[client]-dev[el]). Also, depending on the install location of the MySQL headers, additional parameters to "configure" might be needed (eg. "-I /usr/include/mysql" on OpenSuse).

If you get the Qt4 direct from Nokia, such as a download of qt-sdk-linux-x86_64-opensource-2009.05.bin, you will ( by the command "akonadictl start") get an error at Test 1:

Database driver not found.

Details: The QtSQL driver 'QMYSQL' is required by your current Akonadi server configuration. The following drivers are installed: QSQLITE.

Make sure the required driver is installed.

The driver you need is libqsqlmysql.so

Unfortunately this driver is not part of the distribution (until january 2010). You need to compile the source. Download the following file:

qt-everywhere-opensource-src-4.6.0.tar.bz

Then configure and make as above. But the make install doesn't copy the driver. So you have to copy it by yourself:

cp <qt-src-dir>/qt-everywhere-opensource-src-4.6.0/plugins/sqldrivers/libqsqlmysql.so /usr/local/bin/sqldrivers/

But the Revision 4.6.1, such as qt-sdk-linux-x86_64-opensource-2010.xx.bin has the driver you needed.

Environment Setup

The Akonadi server searches for Akonadi agents and resources in the paths defined in the XDG_DATA_DIRS environment variable. If Akonadi complains about not finding agents or resources, check if this variable is set correctly. Also keep in mind that even if set in a current console session, it might not have been set when starting the server. Starting the server manually in the current console session excludes this cause.

mysqld: unknown variable 'innodb_file_per_table=1'

If the MySQL server log contains the following error, then your MySQL server was built without the InnoDB support which is required by Akonadi or InnoDB needs to be loaded in your mysql.conf file:

[ERROR] /usr/libexec/mysqld: unknown variable 'innodb_file_per_table=1'

[ERROR] Aborting

Try adding:

#sql_mode=strict_trans_tables <- Add underneath this line
  1. plugins

plugin_dir=usr/lib/mysql/plugin < - This may be a different path

plugin-load=ha_innodb.so

Table 'mysql. servers' doesn't exist

If MySQL server log contains the following error, then, most probably, you don't have your MySQL configuration file in place:

[ERROR] Can't open and lock privilege tables: Table 'mysql.servers' doesn't exist

[ERROR] Cannot open mysql.db [ERROR] Cannot open mysql.user

[ERROR] Cannot open mysql.event

Copy it from /usr/share/config/akonadi/mysql-global.conf into ~/.config/akonadi/mysql-local.conf. (For debian and openSuSE users the file is located in /etc/akonadi/mysql-global.conf). Then open it and uncomment the line sql_mode=strict_trans_tables. After that, you may get the following errors:

[ERROR] Plugin 'InnoDB' init function returned error.

[ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed. [ERROR] Unknown/unsupported table type: innodb

[ERROR] Aborting

If so, then in the same file find the line that starts just like the one above (which you have uncommented), but has additional parameters, separated by commas (something like sql_mode=strict_trans_tables,strict_all_tables, ...etc). Comment the shorter sql_mode=... line and uncomment the longer one.

On openSUSE 11.2 running the following command will fix this problem:

mysql_install_db --datadir=$HOME/.local/share/akonadi/db_data/


Kubuntu 10.04 (Lucid Lynx) Upgrade

This is a summary of other entries here for those upgrading from Kubuntu 9.10 to 10.04 who may have been using a personal package archive (PPA) for KDE 4.3 for bug fixes.

Install missing prerequisites. Remove previous akonadi cache. Start the akonadi service. Install the database. Upgrade the database. Stop and restart the akonadi service.

sudo apt-get install virtuoso-server mysql-server-5.1

rm -r $HOME/.local/share/akonadi akonadictl start mysql_install_db --datadir=$HOME/.local/share/akonadi/db_data/ mysql_upgrade --socket=$HOME/.local/share/akonadi/db_misc/mysql.socket akonadictl stop

akonadictl start

The mysql_install_db command above will report something like the following, which you can safely ignore:

Installing MySQL system tables...

100501 18:04:30 [Warning] Can't create test file

/home/[userid]/.local/share/akonadi/db_data/[hostname].lower-test

Reference: forum.kde.org Akonadi 1.2.1 - some issues

KAddressBook upgrade

In addition to the Kubuntu 10.4 remedy above, problems trying to add a Vcard directory may require the following command while Akonadi is not running:

rm -rf $HOME/.config/akonadi

Can't initialize character set latin1

If you get the following error when starting Akonadi, then you are probably using a MySQL server which has a version > 5.1.42:

Character set 'latin1' is not a compiled character set and is not specified in the '/usr/share/mysql/charsets/Index.xml' file

Nepomuk QueryServer interface not available! Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString) DataStore::unhideAllPimItems() Character set 'latin1' is not a compiled character set and is not specified in the '/usr/share/mysql/charsets/Index.xml' file Database error: Cannot open database. Last driver error: "QMYSQL: Unable to connect" Last database error: "Can't initialize character set latin1 (path: /usr/share/mysql/charsets/)" Database error: Cannot open database. Last driver error: "QMYSQL: Unable to connect" Last database error: "Can't initialize character set latin1 (path:

/usr/share/mysql/charsets/)"

There is a known regression in MySQL 5.1.43 and 5.1.44 which prevents MySQL from starting.

See the bug report for more details.


Restarting after a previous error

If you had problems starting Akonadi and fixed those (such as a missing package or the Apparmor problem) make sure that the Akonadi server is completely shut down before trying to start it again, by calling on the command line:

akonadictl stop

You can confirm that it was indeed shut down completely by running:

akonadictl status

Under some circumstances the Akonadi server can be stuck in a partially running state after a failure which will prevent the next attempt to start it to fail as well. Please file a bug report if you run into this problem including the self-test report of the initial problem.

The so-called "Gentoo-Assert"

That's an especially nasty problem that so far only affects users of source-based distributions, most prominently Gentoo. It is named after MySQL assertions like the following example and is most likely caused by a MySQL protocol mismatch between the MySQL server and the client library or the Qt MySQL driver.

akonadiserver: libmysql.c:4301: setup_one_fetch_function: Assertion

`param->buffer_length != 0' failed.

It is extremely hard to diagnose as the assertion mentioned above is only triggered sometimes. Instead you'll get a wide range of weird symptoms:

  • ASAP protocol logs show successful creation of objects which are supposedly no longer available when the next commands access them again.
  • SQL protocol logs show INSERT or UPDATE commands with values that mismatch the corresponding column types and nevertheless succeed.
  • SQL protocol logs showing large apparently random record ids which are nevertheless considered valid.

References:

Possible solution: Rebuild the Qt MySQL driver after upgrading MySQL (which most likely caused this problem in the first place).


Content is available under Creative Commons License SA 4.0 unless otherwise noted.