Kdenlive/Manual/Installation

Revision as of 05:20, 9 June 2015 by Claus chr (talk | contribs)
Jump to: navigation, search
Other languages:
Deutsch • ‎English • ‎dansk • ‎español • ‎français • ‎português do Brasil • ‎русский • ‎українська • ‎中文(台灣)‎

Installation

Installation af binære pakker

Multimediepakker gøres tilgængelige i mange alternative arkiver, ofte på grund af begrænsninger i retten til at distribuere codecs på grund af patenter i nogle lande (for øjeblikket især USA).

I en perfekt verden ville pakkebyggere bidrage til officielle distributioner og de der laver multimedieindhold ville holde sig til frie codecs for at udbrede brugen af dem over hele verden Face-smile.png... Så prøv at holde dig til, hvad din distribution leverer.

De fleste Linux-distributioner udbyder binære pakker for nyere udgaver af Kdenlive, som kan installeres af din pakkehåndtering. Desuden kan du i flere tilfælde finde endnu nyere udgaver i private arkiver.

Denne sideKdenlives websted har instruktioner til, hvordan disse nyere versioner afhænger af, hvilken Linux-distribution du kører. Der findes instruktioner til Debian, Fedora Gentoo, OpenSUSE, Slackware og Ubuntu.

Fra maj 2015 er det blevet lidt kompliceret at hente og installere den seneste version af Kdenlive. Op til dette tidspunkt er udviklingen af Kdenlive sket ved brug af en teknologi kendt som KDE Frameworks 4; den seneste stabile udgave som bruger denne teknologi er version 0.9.10 udgivet d. 25. september 2014.
For at bruge den har du brug for aktuelle udgaver af frei0r, Kdenlive , mlt og libvidstab, fx
frei0r = 1.4.0+git20140826.72e51041
kdenlive = 0.9.10
mlt = 0.9.3+git20141005.22abed67
libvidstab=2:0.98b

Udviklingen af Kdenlive er nu overgået til en version af KDE Frameworks kaldet KF5 (KDE Frameworks 5). For at installere versioner af Kdenlive, som bruger denne underliggende teknologi skal du bruge en Linux-distribution, som understøtter KF5. Ubuntu og dens afledede understøtter KF5 fra version 15.04. Det er ikke muligt at installere KF5 på tidligere versioner end 15.04 (medmindre du chrooter dit system). Versioner, som bruger KF5 distribueres af Kubuntus CI-team. KF5-versionen distribueres ikke i ppa'en sunab (se nedenfor).
Versionsnumre for KF5-varianten starter ved 10.04.0

Skiftet fra 0.9.10 til 15.0.4 er ganske stort med hensyn til det krævede udviklingsarbejde. Testning af den nye version 15.04.0 har været ret begrænset. Til kritisk arbejde anbefaler jeg ikke at opgradere til 15.04.0 medmindre du har en god backup-strategi — hvilket kunne betyde at kunne gå tilbage fra en opgradering af din distribution (jeg er ikke sikker på om du kan køre KDE Frameworks 4 på Ubuntu 15.04 eller afledte distroer).

Debian

Debian-projektet leverer pakker med Kdenlive fra "squeeze"-udgaven (6.0), men for at drage nytte af de seneste opdateringer og fejlrettelser, så kan du overveje at opgradere til en "testing"-udgave eller endda "sid".

Når dit pakkehåndteringssystem er sat til en passende udgivelse burde det være nok blot at køre kommandoen apt-get install kdenlive.

Sunabs PPA (se ovenfor) anbefales ikke til Debian-brugere, da Debian bruger et anderledes layout til multiarch (reference: dette indlæg fra vpinion)

Ubuntu og afledede distributioner

Ubuntu leverer også Kdenlive siden "gutsy" (7.10), men for at drage fordel af aktuelle udgivelser og fejlretninger bør du overveje at opgradere til den seneste udgave.

Sunab udbyder en stabil udgivelse af Kdenlive (KDE Frameworks 4 udgaven) fra dette PPA.

Når dit pakkehåndteringssystem er sat til en passende udgivelse burde det være nok blot at køre kommandoen apt-get install kdenlive.

Bemærk, at Sunabs PPA er bygget med multimedisarkiverne avconv, som ubuntu/lubuntu/kbuntu etc leveres med. Det er ikke bygget med det "alternative" multimediearkiv ffmpeg, som bruges af nogle andre distributioner. Derfor kan det give problemer at bruge dette PPA på distributioner, som ikke anvender avconv. (Mange tak avconv/ffmpeg-skisma !!!!).

Fedora, RedHat og afledede distributioner

RPM-pakker vedligeholdes endnu ikke i den officielle gren, så du må bruge et uofficielt arkiv som RPM Fusion eller packman. Følg sidernes anbefalinger for at gøre arkivet tilgængeligt og slut af med yum install kdenlive.

Gentoo, Arch, BSD-oversættelser

Er dit system up-to-date, så findes der scripts til bygning; kør henholdsvis emerge kdenlive, pacman -S kdenlive eller pkg_add kdenlive, etc.

Windows

Der er endnu ingen version af Kdenlive, som kører direkte i Windows. Du kan dog bruge en virtualiseret Linux-distribution til at køre KdenliveWindows. Du kan finde nogle råd på denne side

Der er også et projekt med kdenlive på Windows på SourceForge, som "består af et VirtualBox-billede med Ubuntu, som er forudkonfigureret til køre Kdenlive". Projektet blev senest opdateret d 9/8 2012.

MacOS

Kdenlive og MLT kan kompileres og køre under Mac OS X. Du kan få pakker fra projektet MacPorts.

MacPorts er et kilde-baseret system - der er ingen binær programpakke af Kdenlive. Derfor skal Kdenlive og alle dens mange afhængigheder, herunder multimedie-biblioteker, KDE og Qt kompileres. Dette kan tage lang tid og bruge megen plads på harddisken! Desuden er det ikke usædvanligt, at et eller andet ikke bygger korrekt: det er bestemt ikke for nybegyndere, utålmodige eller ængstelige sjæle.

Find flere detaljer her

Du kan have held med at få support til PacPort'en Kdenlive på Mac Ports forum på MacOS Forge.

Installation fra kildekoden

Hvis du vil teste den senest indsendte kode eller dine egne ændringer, så skal du selv bygge Kdenlive (og nok også MLT).

Du kan bruge din distributions pakkebygnings-procedure og således bruge dens system til at håndtere software til at installere, opgradere og fjerne de binære filer og data og i sidste enden lade andre bruge din version (og endda bidrage til vedligeholdeles af pakken - se mere i din distributions manual).

Hvis du vil, kan du bygge og installere Kdenlive i en lokal mappe (helse ikke /usr, $HOME/my_local_builds/kdenlive-last-release eller lignende). Det anbefales så at bruge bygningsscriptet[1] (Følg instruktionerne under "show kdenlive". Disse instruktioner vil bygge Kdenlive og dens afhængigheder [fx melt og ffmpeg] i en "sandboks").

Installation fra Sunabs PPA

Olivier Banus (AKA Sunab) udbyder et personligt pakkearkiv (PPA) med den seneste udviklingsversion af Frei0r-pluginene, MLT og Kdenlive. For detaljer om hvordan man installerer Kdenlive fra denne hyperaktuelle kilde se launchpad.net - kdenlive-git (unstable). Kun til testning!

Bemærk: Sunab vedligeholder også et PPA af den officielle, aktuelle udgivelse af Kdenlive (som bemærket ovenfor) samt den forrige udgivelse på ppa:sunab/kdenlive-release-old.

Hvis du ønsker at gå tilbage til den forrige udgivelse så:

  • slet alle pakker (kdenlive, mlt, ...) fra kdenlive-release ppa'en (manuelt eller med ppa-purge)
  • aktivér ppa:sunab/kdenlive-release-old i pakkemanagerens softwarekilder
  • installér Kdenlive fra ppa:sunab/kdenlive-release-old

Installation fra daglig bygning

Dan Dennedy udbyder automatiske, daglige bygninger, som indeholder den seneste git-version af Kdenlive, MLT, Frei0r, FFmpeg og nogle andre vigtige biblioteker. Du kan teste disse pakker uden at ændre dit system. Download blot pakken og pak den ud i en mappe efter eget valg. I denne mappe er der en kørbar fil, "start-kdenlive", som starter den seneste udgave af Kdenlive for dig.

Kør denne ved at skrive ./start-kdenlive i en terminal.

Daglige bygninger udbydes i øjeblikket til Ubuntu (skulle være kompatible med OpenSuse 12 og Debian 7) og Fedora.

Se rss feed'et daily builds, som giver links til bygninger for ovennævnte distributioner.

Sørg for at vælge det rette download til dit system.

kdenlive-fedora17-x86_64-YYYYMMDD.tar.bz2 er til 64bit Fedora
kdenlive-ubuntu12.04-x86_64-YYYYMMDD.tar.bz2 er til 64bit Ubuntu - (version 12.04 og senere) og andre Debian-baserede distributioner
kdenlive-ubuntu14.04-x86-YYYYMMDD.tar.bz2 (uden 64 i navnet) et til 32bit Ubuntu - (version 14.04 og senere) og andre Debian-baserede distributioner


Daglige bygninger er ofte en nem løsning, hvis du har problemer med din installation og kan være at foretrække frem for at bygge selv, fordi du ikke behøver at installere et bygge-miljø (som kan være et problem på en gammel distribution).

Daglige bygninger fungerer sandsynligvis, selv hvis din distribution ikke matcher referencedistributionerne, da disse referencer er ældre (med opdaterede kompatibilitetsbiblioteker), og de vigtige biblioteker er indlejrede - det virker som regel uden problemer.

Den mulige ulempe er, at de daglige bygninger bygges fra den ustabile udviklingsstrøm og kan indeholde bugs. På den anden side kan din daglige bygning og hovedversionen af Kdenlive leve side om side på din maskine.

Se også Kdenlives hjemmeside

  1. i distributioner ældre end Debian 6 eller Ubuntu 10.04 og afledede skal du sætte ENABLE_SWFDEC=0 i scriptets config-variable. Ret INSTALL_DIR i scriptet til noget i retning af INSTALL_DIR="$HOME/my_local_builds/kdenlive-last-release" for at tilpasse det til, hvor du ønsker at installere den lokale version.

Content is available under Creative Commons License SA 4.0 unless otherwise noted.