Kdenlive/Manual/Installation

Revision as of 09:40, 20 April 2016 by FuzzyBot (talk | contribs) (Updating to match new version of source page)
Jump to: navigation, search
Other languages:
Deutsch • ‎English • ‎dansk • ‎español • ‎français • ‎português do Brasil • ‎русский • ‎українська • ‎中文(台灣)‎

Installation

Installation af binære pakker

De fleste distributioner har binære pakker af Kdenlive, som er up-to-date og kan installeres fra dit pakkehåndteringsprogram. Dog findes der i nogle tilfælde nyere versioner i private arkiver.

Denne sideKdenlives websted har instruktioner til, hvordan disse nyere versioner afhænger af, hvilken Linux-distribution du kører. Der findes instruktioner til Debian, Fedora Gentoo, OpenSUSE, Slackware og Ubuntu.


Fra maj 2015 er det blevet lidt mere kompliceret at finde og installere den seneste version af Kdenlive. Indtil da har Kdenlive brugt en teknologi kendt som KDE Frameworks 4. Den seneste stabile version af denne teknologi er 0.9.10, udgivet d. 25. september 2014.
For ar bruge den skal du bruge en aktuel version af frei0r, Kdenlive, mlt og libvidstab, fx:

  • frei0r = 1.4.0+git20140826.72e51041
  • Kdenlive = 0.9.10
  • mlt = 0.9.3+git20141005.22abed67
  • libvidstab=2:0.98b


Fra juni 2015 har denne PPA version 0.9.10 fa Kdenlive, 1.4.0 of Frei0r og 0.9.3 of melt.

Development of Kdenlive has now switched to a new version of the KDE Frameworks called KF5 (KDE Frameworks 5). To install versions of Kdenlive using this underlying technology, you need to be on a Linux distribution which supports KF5. Ubuntu and its derivatives versioned 15.04 and higher support KF5. It is not possible to install KF5 on distributions earlier than 15.04 (except by chrooting your system). Versions using KF5 are distributed by the Kubuntu-CI Team. The sunab ppa (see below) now also distributes KF5 versions.
Version numbers of the KF5 flavour start at 15.04.0.
This author recommends using the sunab ppa to install Kdenlive rather than the Kubuntu-CI Team because the Kubuntu-CI Team PPA has many other packages in it which will attempt to uprade all sorts of things on your system—with the potential of breaking it.

Skiftet fra 0.9.10 til 15.0.4 er ganske stort med hensyn til det krævede udviklingsarbejde. Testning af den nye version 15.04.0 har været ret begrænset. Til kritisk arbejde anbefaler jeg ikke at opgradere til 15.04.0 medmindre du har en god backup-strategi. Tilsyneladende har standardarkiverne for Ububtu 15.04 version 0.9.10 af Kdenlive kørende under KDE Frameworks 4, så det er måske muligt at gå tilbage fra 15.04.x til 0.9.10 ved at fjerne ppa-versionen af Kdenlive og geninstallere fra standardarkiverne.

Debian

Debian-projektet leverer pakker med Kdenlive fra "squeeze"-udgaven (6.0), men for at drage nytte af de seneste opdateringer og fejlrettelser, så kan du overveje at opgradere til en "testing"-udgave eller endda "sid".

Når dit pakkehåndteringssystem er sat til en passende udgivelse burde det være nok blot at køre kommandoen apt-get install kdenlive.

Sunabs PPA (se ovenfor) anbefales ikke til Debian-brugere, da Debian bruger et anderledes layout til multiarch (reference: dette indlæg fra vpinion)

Ubuntu og afledede distributioner

Ubuntu leverer også Kdenlive siden "gutsy" (7.10), men for at drage fordel af aktuelle udgivelser og fejlretninger bør du overveje at opgradere til den seneste udgave.

ppa:kdenlive/kdenlive-master is the development branch, with the very latest features additions.

ppa:kdenlive/kdenlive-testing is the feature-frozen branch, starting from the first beta, with bugfix updates as soon as solutions are found

ppa:kdenlive/kdenlive-stable is the last robust official release

Sunab offers a stable release of Kdenlive (version 15.12.1 as at 2nd March 2016) from this PPA.

Han vedligeholder et ppa med den forrige version her. Fra juni 2015 er det ver. 0.9.10 af Kdenlive, 1.4.0 af Frei0r og 0.9.3 af melt.


Ikke alle pakker i ppa'et er nødvendige. Installér eller opdatér følgende for at få version til 15.04 (versionsnumre fra 13 juli 2015)

  • kdenlive (15.04.2-0ubuntu0-~sunab~vivid4)
  • kdenlive-data (15.04.2-0ubuntu0-~sunab~vivid4)
  • libmlt++3 (0.9.6-0ubuntu0~sunab~vivid1)
  • libmlt-data (0.9.6-0ubuntu0~sunab~vivid1)
  • libmlt6 (0.9.6-0ubuntu0~sunab~vivid1)
  • libvidstab1.0 (2:0.98b-0ubuntu0~sunab~vivid1)
  • melt ( 0.9.6-0ubuntu0~sunab~vivid1)

Non-Kubuntu users will need to install the kde-runtime package to fix missing buttons and icons.

Bemærk, at Sunabs PPA er bygget med multimedisarkiverne avconv, som ubuntu/lubuntu/kbuntu etc leveres med. Det er ikke bygget med det "alternative" multimediearkiv ffmpeg, som bruges af nogle andre distributioner. Derfor kan det give problemer at bruge dette PPA på distributioner, som ikke anvender avconv. (Mange tak avconv/ffmpeg-skisma !!!!).

Fedora, RedHat og afledede distributioner

RPM packages are not yet maintained in an official branch, so you must go through an unofficial repository such as RPM Fusion or packman (Has ver 15.12.0 29 Dec 2015). Follow the site's recommendations to make them available and end with yum install kdenlive.

Gentoo, Arch, BSD-oversættelser

Er dit system up-to-date, så findes der scripts til bygning; kør henholdsvis emerge kdenlive, pacman -S kdenlive eller pkg_add kdenlive, etc.

Windows

Der er endnu ingen version af Kdenlive, som kører direkte i Windows. Du kan dog bruge en virtualiseret Linux-distribution til at køre KdenliveWindows. Du kan finde nogle råd på denne side

Der er også et projekt med kdenlive på Windows på SourceForge, som "består af et VirtualBox-billede med Ubuntu, som er forudkonfigureret til køre Kdenlive". Projektet blev senest opdateret d 9/8 2012.

MacOS

Kdenlive og MLT kan kompileres og køre under Mac OS X. Du kan få pakker fra projektet MacPorts.

MacPorts er et kilde-baseret system — der er ingen binær programpakke af Kdenlive. Derfor skal Kdenlive og alle dens mange afhængigheder, herunder multimedie-biblioteker, KDE og Qt kompileres. Dette kan tage lang tid og bruge megen plads på harddisken! Desuden er det ikke usædvanligt, at et eller andet ikke bygger korrekt: det er bestemt ikke for nybegyndere, utålmodige eller ængstelige sjæle.

Find flere detaljer her

Du kan have held med at få support til PacPort'en Kdenlive på Mac Ports forum på MacOS Forge.

Installation fra kildekoden

Hvis du vil teste den senest indsendte kode eller dine egne ændringer, så skal du selv bygge Kdenlive (og nok også MLT).

Details on how to compile and install Kdenlive from source are available on the Community wiki.

Du kan bruge din distributions pakkebygnings-procedure og således bruge dens system til at håndtere software til at installere, opgradere og fjerne de binære filer og data og i sidste enden lade andre bruge din version (og endda bidrage til vedligeholdeles af pakken - se mere i din distributions manual).

If you prefer you can build & install Kdenlive to a local area (preferably not /usr, but rather /usr/local or $HOME/my_local_builds/kdenlive-last-release or similar). You could try using this build script to build the latest version from the sources. Or you could use the this build script to build kdenlive ver 0.9.10 [1] (Follow the instructions under "show kdenlive". These instructions will build Kdenlive and its dependancies [e.g. melt, ffmpeg] in a "sandbox").

Installation fra Sunabs PPA

Olivier Banus (AKA Sunab) udbyder et personligt pakkearkiv (PPA) med den seneste udviklingsversion af Frei0r-pluginene, MLT og Kdenlive. For detaljer om hvordan man installerer Kdenlive fra denne hyperaktuelle kilde se launchpad.net - kdenlive-git (unstable). Kun til testning!

As of 2 Dec 2015 Sunab has included a build for Ubuntu 15.10—the wily werewolf.

Bemærk: Sunab vedligeholder også et PPA af den officielle, aktuelle udgivelse af Kdenlive (som bemærket ovenfor) samt den forrige udgivelse på ppa:sunab/kdenlive-release-old.

Hvis du ønsker at gå tilbage til den forrige udgivelse så:

  • slet alle pakker (kdenlive, mlt, ...) fra kdenlive-release ppa'en (manuelt eller med ppa-purge)
  • aktivér ppa:sunab/kdenlive-release-old i pakkemanagerens softwarekilder
  • installér Kdenlive fra ppa:sunab/kdenlive-release-old

Installing from pre-built binary packages

Kdenlive developer Vpinon is making available compressed pre-built binary files for installing from http://files.kde.org/kdenlive/.

You can test these packages without changing your system. Just download the package and extract it to a folder of your choice. Inside that folder is a "start-kdenlive" executable that will start for you a recent version of Kdenlive.

Execute this by typing ./start-kdenlive in a terminal.

Pre-built binary packages are often an easy solution if you are having troubles with your install and can be preferable to building your own because you don't need to install a build environment.

The potential downside is that the pre-built binary packages are built from the unstable development stream and may contain bugs. On the plus side, your pre-built binary packages version and your main version of Kdenlive can live simultaneously on your machine.

Another downside is that these packages have been built with a version of ffmpeg that only has the free video codecs. The type of files you can render your video to is limited. Choosing the Theora profile in the Web Sites rendering destination does work.

Installing from daily builds - Old Versions

Dan Dennedy of the Melt project used to provide automatic daily builds that contained the latest git versions of Kdenlive, MLT, Frei0r, FFmpeg and some other important libraries. However, the melt project's daily builds have not switched over to the 15.xx branch of Kdenlive so these instructions will not give you the bleeding edge code.

You can test these packages without changing your system. Just download the package and extract it to a folder of your choice. Inside that folder is a "start-kdenlive" executable that will start for you the latest Kdenlive.

Kør denne ved at skrive ./start-kdenlive i en terminal.

Daily builds are currently provided for Ubuntu (should be compatible with OpenSUSE 12 and Debian 7) .

Se rss feed'et daily builds, som giver links til bygninger for ovennævnte distributioner.

Be sure to choose the correct download for the bitness your system:

kdenlive-debian7-x86_64-YYYYMMDD.tar.bz2 is for 64-bit Debian or Ubuntu-based distros. (As at October 2015 this is still a 0.9.10 version of Kdenlive).
kdenlive-ubuntu14.04-x86-YYYYMMDD.tar.bz2 (no 64 in the name ) is for 32-bit Ubuntu—(release 14.04 or higher) or other Debian-based distros.

Daily builds are often an easy solution if you are having troubles with your install and can be preferable to building your own because you don't need to install a build environment (which can be problematic on old distros).

Daily builds are likely to work even if your distro doesn't match the reference ones, as these references are older (with ascendant compatibility libs) and the important libs are embedded—they normally work without a problem.

The potential downside is that the daily builds are built from the unstable development stream and may contain bugs. On the plus side, your daily build version and your main version of Kdenlive can live simultaneously on your machine.

Se også Kdenlives hjemmeside

  1. on distributions older than Debian 6 or Ubuntu 10.04 and derivatives, you need to set ENABLE_SWFDEC=0 in the config variables of the script. Modify the INSTALL_DIR in the script to something like INSTALL_DIR="$HOME/my_local_builds/kdenlive-last-release" to make it match where you want this local build to install.

Content is available under Creative Commons License SA 4.0 unless otherwise noted.