(Created page with "==== Ubuntu y derivados ==== ''Ubuntu'' también ha ofrecido '''Kdenlive''' desde "Gutsy" (7.10). Sin embargo, para beneficiarse de las actualizaciones recientes y reparación...")
(Created page with "Sunab ofrece un lanzamiento estable de Kdenlive (KF 5 versión 15.04.x) desde [https://launchpad.net/~sunab/+archive/kdenlive-release este] PPA.")
Line 40: Line 40:
 
''Ubuntu'' también ha ofrecido '''Kdenlive''' desde "Gutsy" (7.10). Sin embargo, para beneficiarse de las actualizaciones recientes y reparación de errores, debería considerar actualizar al último lanzamiento.
 
''Ubuntu'' también ha ofrecido '''Kdenlive''' desde "Gutsy" (7.10). Sin embargo, para beneficiarse de las actualizaciones recientes y reparación de errores, debería considerar actualizar al último lanzamiento.
  
Sunab offers a stable release of Kdenlive (KF 5 version 15.04.x) from [https://launchpad.net/~sunab/+archive/kdenlive-release this] PPA.
+
Sunab ofrece un lanzamiento estable de Kdenlive (KF 5 versión 15.04.x) desde [https://launchpad.net/~sunab/+archive/kdenlive-release este] PPA.
  
 
He maintains a ppa with the previous release  [https://launchpad.net/~sunab/+archive/ubuntu/kdenlive-release-old here]. As at June 2015 it has the ver 0.9.10 of '''Kdenlive''' , 1.4.0 of Frei0r and 0.9.3 of melt
 
He maintains a ppa with the previous release  [https://launchpad.net/~sunab/+archive/ubuntu/kdenlive-release-old here]. As at June 2015 it has the ver 0.9.10 of '''Kdenlive''' , 1.4.0 of Frei0r and 0.9.3 of melt

Revision as of 18:22, 4 September 2015

Other languages:
Deutsch • ‎English • ‎dansk • ‎español • ‎français • ‎português do Brasil • ‎Ελληνικά • ‎русский • ‎українська • ‎中文(台灣)‎

Instalación

Instalar paquetes binarios

La mayoría de las distribuciones de GNU/Linux proporcionan paquetes binarios recientes de Kdenlive que se pueden instalar desde su Administrador de Paquetes. Sin embargo, en algunos casos es posible encontrar versiones más recientes en repositorios privados.

Esta página en Kdenlive tiene instrucciones sobre cómo usar esas versiones más recientes, dependiendo de qué distro de GNU/Linux usa. Hay instrucciones disponibles para Debian, Fedora, Gentoo, OpenSUSE, Slackware y Ubuntu.


Desde mayo de 2015, obtener e instalar la versión más reciente de Kdenlive se ha complicado un poco. El desarrollo de Kdenlive usa desde ese momento una tecnología conocida como KDE Frameworks 4 y la versión estable más reciente que la utiliza es la 0.9.10, lanzada el 25 de septiembre de 2014.
Para usarla necesita versiones recientes de frei0r, Kdenlive , mlt y libvidstab, v.g.:

  • frei0r = 1.4.0+git20140826.72e51041
  • Kdenlive = 0.9.10
  • mlt = 0.9.3+git20141005.22abed67
  • libvidstab=2:0.98b


Desde junio de 2015, esta PPA tiene la versión 0.9.10 de Kdenlive, 1.4.0 de Frei0r y 0.9.3 de melt.

El desarrollo de Kdenlive ahora ha cambiado a una nueva versión de KDE framework llamados Rf5 (framework KDE 5). Para instalar las versiones de Kdenlive utilizando esta tecnología subyacente, necesita estar en una distribución de GNU/Linux que soporta Rf5. Ubuntu y sus derivados desde la versión 15,04 y superior soportan Rf5. No es posible instalar Rf5 en distribuciones anteriores a 15.04 (excepto chrooteando su sistema). Las versiones que usan Rf5 se distribuyen por el [Equipo Kbuntu-CI https://launchpad.net/~kubuntu-ci]. Los PPA sunab (ver más abajo) ahora también distribuyen versiones Rf5.
Los números de versión del sabor Rf5 comienzan en 15.04.0.
Se recomienda utilizar el PPA sunab para instalar Kdenlive en lugar del equipo de Kubuntu-CI porque el PPA de este equipo tiene muchos otros paquetes, que intentarán actualizar todo tipo de cosas en su sistema, con el potencial de dañarlo.

El cambio entre 0.9.10 y 15.04.0 es bastante importante con respecto al trabajo de desarrollo necesario. Las pruebas de la nueva versión 15.04.0 se han limitado. Para trabajos críticos se recomendaría 'no' actualizar a 15.04.0 a menos que tenga una buena estrategia de restitución. Parece que los repositorios estándar 15.04 de Ubuntu tienen una versión 0.9.10 de Kdenlive corriendo contra framework KDE 4 por lo que podría ser capaz de retirarse de 15.04.x a 0.9.10 purgando la versión PPA de Kdenlive y volver a instalar el que está en los repositorios estándar.

Debian

El proyecto Debian ha estado lanzando paquetes Kdenlive desde el lanzamiento de "squeeze". Sin embargo, para beneficiarse de las últimas actualizaciones y correcciones de errores, usted podría considerar la actualización a una versión "pruebas" o incluso "sid"

Una vez que su herramienta de gestión de paquetes se apunta a un lanzamiento apropiado, un simple apt-get install kdenlive a continuación, debería funcionar.

El PPA de sunab (ver más abajo) no es recomendable para Debian porque Debian usa una capa lib diferente para multiarch (referencia: este post de vpinon).

Ubuntu y derivados

Ubuntu también ha ofrecido Kdenlive desde "Gutsy" (7.10). Sin embargo, para beneficiarse de las actualizaciones recientes y reparación de errores, debería considerar actualizar al último lanzamiento.

Sunab ofrece un lanzamiento estable de Kdenlive (KF 5 versión 15.04.x) desde este PPA.

He maintains a ppa with the previous release here. As at June 2015 it has the ver 0.9.10 of Kdenlive , 1.4.0 of Frei0r and 0.9.3 of melt


Not all the packages in the ppa are necessary. Install or upgrade the following to get a 15.04 release (version numbers as at 13 July 2015)

  • kdenlive (15.04.2-0ubuntu0-~sunab~vivid4)
  • kdenlive-data (15.04.2-0ubuntu0-~sunab~vivid4)
  • libmlt++3 (0.9.6-0ubuntu0~sunab~vivid1)
  • libmlt-data (0.9.6-0ubuntu0~sunab~vivid1)
  • libmlt6 (0.9.6-0ubuntu0~sunab~vivid1)
  • libvidstab1.0 (2:0.98b-0ubuntu0~sunab~vivid1)
  • melt ( 0.9.6-0ubuntu0~sunab~vivid1)

Note that Sunab's PPA is built against the avconv multimedia libraries which Ubuntu/Lubuntu/Kubuntu et al. ship with. It is not built against the "alternative" ffmpeg multimedia libraries that other distros might have. So using this PPA for non-avconv-utilizing distributions might be problematic. (Thanks avconv/ffmpeg schism !!!!).

Fedora, RedHat and derivatives

RPM packages are not yet maintained in an official branch, so you must go through an unofficial repository such as RPM Fusion or packman. Follow the site's recommendations to make them available and end with yum install kdenlive.

Gentoo, Arch, BSD ports

Building scripts are ready for up-to-date systems, so run respectively emerge kdenlive or pacman -S kdenlive or pkg_add kdenlive, etc.

Windows

There is no native Windows version of Kdenlive yet. However, you can use some virtualized Linux distribution to run Kdenlive on Windows. Some advice can be found on this page.

There is also the kdenlive on win project on SourceForge which "consists of an Ubuntu VirtualBox image that is preconfigured to run Kdenlive". The project was last updated 2012-08-09.

MacOS

Kdenlive and MLT can compile and run under Mac OS X. Packages are available from the MacPorts project.

MacPorts is a source-based system — there is not a binary app bundle for Kdenlive. Therefore, Kdenlive and all of its numerous dependencies, including multimedia libraries, KDE, and Qt, must be compiled. This can take a long time and much disk space! Furthermore, it is not unusual for something not to build correctly; it is definitely not something for the novice, impatient, or "faint of heart".

For more details see this.

You may have some success getting support for the MacPort of Kdenlive on the Mac Ports forum on MacOS Forge.

Installing from source

If you want to test latest committed code or your personal patches, you will have to build Kdenlive (and probably MLT) on your own.

You can use your distribution's package building procedure to use its software management system to install/upgrade/remove the binaries and data, and eventually share your builds (and even contribute to package maintenance - refer to the respective distribution manual).

If you prefer you can build & install Kdenlive to a local area (preferably not /usr, but rather /usr/local or $HOME/my_local_builds/kdenlive-last-release or similar). It is then recommended to use the build script [1] (Follow the instructions under "show kdenlive". These instructions will build Kdenlive and its dependancies [e.g. melt, ffmpeg] in a "sandbox").

Installing from Sunab's PPA

Olivier Banus (AKA Sunab) provides a personal package archive (PPA) of the latest development trees of Frei0r-plugins, MLT and Kdenlive. For details on how to install Kdenlive using this bleeding edge source see launchpad.net - kdenlive-git (unstable).Testing only!

Note: Sunab also maintains a PPA of the offical current release of Kdenlive (as noted above) as well as the current release minus one at ppa:sunab/kdenlive-release-old.

If you need to back out a release to the previous release then:

  • delete all packages (kdenlive, mlt, ...) from the kdenlive-release ppa (manually or with ppa-purge)
  • disable ppa:sunab/kdenlive-release in the package manager/software sources
  • enable the ppa:sunab/kdenlive-release-old in the package manager/software sources
  • install Kdenlive from ppa:sunab/kdenlive-release-old

Installing from daily builds

Dan Dennedy provides automatic daily builds that contain the latest git versions of Kdenlive, MLT, Frei0r, FFmpeg and some other important libraries. Note: It looks like the daily builds have not switched over to the ver 15.04 branch. So this will not give you the bleeding edge code.

You can test this packages without changing your system. Just download the package and extract it to a folder of your choice. Inside that folder is a "start-kdenlive" executable that will start for you the latest Kdenlive.

Execute this by typing ./start-kdenlive in a terminal.

Daily builds are currently provided for Ubuntu (should be compatible with OpenSuse 12 and Debian 7) and Fedora.

See the daily builds rss feed which provides links to the builds for the above mentioned distributions.

Be sure to choose the correct download for your system.

kdenlive-fedora17-x86_64-YYYYMMDD.tar.bz2 is for 64bit Fedora
kdenlive-ubuntu12.04-x86_64-YYYYMMDD.tar.bz2 is for 64bit Ubuntu - (release 12.04 or higher) or other Debian based distros
kdenlive-ubuntu14.04-x86-YYYYMMDD.tar.bz2 (no 64 in the name ) is for 32bit Ubuntu - (release 14.04 or higher) or other Debian based distros


Daily builds are often an easy solution if you are having troubles with your instal and can be preferable to builing your own because you don't need to install a build environment (which can be problematic on old distro).

Daily builds are likely to work even if your distro doesn't match the reference ones, as these references are older (with ascendant compatibility libs) and the important libs are embedded - it normally works without problem.

The potential downside is that the daily builds are built from the unstable development stream and may contain bugs. On the plus side your daily build version and your main version of Kdenlive can live simultaneously on your machine.

See also Kdenlive homepage

  1. on distributions older than Debian 6 or Ubuntu 10.04 and derivatives, you need to set ENABLE_SWFDEC=0 in the config variables of the script. Modify the INSTALL_DIR in the script to something like INSTALL_DIR="$HOME/my_local_builds/kdenlive-last-release" to make it match where you want this local build to install.

Content is available under Creative Commons License SA 4.0 unless otherwise noted.