Kdenlive/Manuel/Installation

Revision as of 10:51, 10 October 2014 by FuzzyBot (talk | contribs) (Updating to match new version of source page)
Jump to: navigation, search
Other languages:
Deutsch • ‎English • ‎dansk • ‎español • ‎français • ‎português do Brasil • ‎русский • ‎українська • ‎中文(台灣)‎

Installation

Installation de paquets binaires

Des paquets Multimédia sont disponibles dans de nombreux stockages alternatifs, principalement à cause de certaines restrictions de distributions sur les codecs disponibles qui sont en rapport avec les brevets dans certains pays (principalement les États-Unis pour le moment).

Tout serait parfait dans le meilleur des mondes si les éditeurs de paquets contribuaient aux distributions officielles. Ainsi les éditeurs multimédia choisiraient seulement des codecs gratuit pour promouvoir leur utilisation partout dans le monde Face-smile.png... Glisserons-nous vers les sources des distributions?

Most linux distributions provide recent binary packages of Kdenlive that can be installed from your Package Manager. However, in some cases you can find more recent versions in private repositories.

This page at the Kdenlive home has instructions on how to source these more recent versions depending on what flavour of Linux you run. Instructions for Debian, Fedora Gentoo, OpenSUSE, Slackware and Ubuntu are available.

The current stable release is version 0.9.10 released 25th September 2014.
You need to have recent versions of frei0r, kdenlive , mlt and libvidstab e.g.
frei0r = 1.4.0+git20140826.72e51041
kdenlive = 0.9.10
mlt = 0.9.3+git20141005.22abed67
libvidstab=2:0.98b

Debian, Ubuntu et dérivés

Debian project ships Kdenlive packages since "squeeze" (6.0) release, however to benefit from recent updates and bugfixes you might consider upgrading to a "testing" release or even "sid".

Ubuntu also offers Kdenlive since "gutsy" (7.10), but for similar reasons it could be preferable to upgrade to the latest release.

Dans les deux cas, un simple apt-get install kdenlive devrait fonctionner.

Sunab offers a stable release of Kdenlive from this PPA

Fedora, RedHat and derivatives

RPM packages are not yet maintained in official branch, so you must go through an unofficial repository such as RPM Fusion or packman. Follow the sites recommendations to make them available and end with yum install kdenlive

Gentoo, Arch, BSD ports

Building scripts are ready for up-to-date systems, so run respectively emerge kdenlive or pacman -S kdenlive or pkg_add kdenlive, etc.

Windows

There is no native Windows version of Kdenlive yet. However, you can use some virtualized Linux distribution to run Kdenlive on Windows. Some advices can be found on this page.

MacOS

Kdenlive and MLT can compile and run under Mac OS X. Packages are available from the MacPorts project.

MacPorts is a source-based system - there is not a binary app bundle for Kdenlive. Therefore, Kdenlive and all of its numerous dependencies including multimedia libraries, KDE, and Qt must be compiled. This can take a long time and much disk space! Furthermore, it is not unusual for something not to build correctly; it is definitely not something for the novice, impatient, or "faint of heart."

For more details see this

You may have some success getting support for the MacPort of kdenlive on the Mac Ports forum on MacOS Forge

Installing from source

If you want to test latest committed code or your personal patches, you will have to build Kdenlive (and probably MLT) on your own.

You can use your distribution's package building procedure to use its software management system to install/upgrade/remove the binaries and data, and eventually share your builds (and even contribute to package maintenance - refer to the respective distribution manual).

If you prefer you can build & install Kdenlive to a local area (preferably not /usr, but rather /usr/local or $HOME/my_local_builds/kdenlive-last-release or similar). It is then recommended to use the build script [1]

Installing from Sunabs PPA

Olivier Banus (AKA Sunab) provides a personal package archive (PPA) of the latest development trees of Frei0r-plugins, MLT and Kdenlive. For details on how to install Kdenlive using this bleeding edge source see launchpad.net - kdenlive-git (unstable).Testing only!

Note: Sunab also maintains a PPA of the offical current release of kdenlive (as noted above) as well as the current release minus one at ppa:sunab/kdenlive-release-old

If you need to backout a release to the previous release then:

  • delete all packages (kdenlive, mlt, ...) from the kdenlive-release ppa (manually or with ppa-purge)
  • disable ppa:sunab/kdenlive-release in the package manager/software sources
  • enable the ppa:sunab/kdenlive-release-old in the package manager/software sources
  • install kdenlive from ppa:sunab/kdenlive-release-old

Installing from daily builds

Dan Dennedy provides automatic daily builds that contain the latest git versions of Kdenlive, MLT, Frei0r, FFmpeg and some other important libraries. You can test this packages without changing your system. Just download the package and extract it to a folder of your choice. Inside that folder is a "start-kdenlive" executable that will start for you the latest Kdenlive.

Execute this by typing ./start-kdenlive in a terminal

Daily builds are currently provided for Ubuntu (should be compatible with OpenSuse 12 and Debian 7) and Fedora.

See the daily builds rss feed which provides links to the builds for the above mentioned distributions.

Be sure to choose the correct download for your system.

kdenlive-fedora17-x86_64-YYYYMMDD.tar.bz2 is for 64bit fedora
kdenlive-ubuntu12.04-x86_64-YYYYMMDD.tar.bz2 is for 64bit ubuntu - (release 12.04 or higher) or other debian based distros
kdenlive-ubuntu12.04-x86-YYYYMMDD.tar.bz2 (no 64 in the name ) is for 32bit ubuntu - (release 12.04 or higher) or other debian based distros

See also Kdenlive homepage

  1. on distributions older than Debian 6 or Ubuntu 10.04 and derivatives, you need to set ENABLE_SWFDEC=0 in the config variables of the script

Content is available under Creative Commons License SA 4.0 unless otherwise noted.