Problems with redirected pages

Jump to: navigation, search

Page redirection does not work with the translation system! See for example the first two links in Plasma#Further information: Plasma/FAQ redirects to Plasma/FAQ/4.4. However, for the Special:myLanguage 'trick' to work we would need a Plasma/FAQ/da redirect to Plasma/FAQ/4.4/da and so on for each translation. (I assume this would work.)

This kind of solution does not seem to be maintainable. I don't see any solution to this problem that is both maintainable and elegant, so I propose a simple, maintainable but not very elegant solution:

Create an actual Plasma/FAQ page containing only links to the various versions of the FAQ. That way, when a new version of the FAQ is created, we just add a link to it here. Of course this link page should be translated. (Perhaps it would be easier to create a new Plasma/FAQ/Index page and change all links to Plasma/FAQ to this page?)

10:11, 23 December 2010

Do you have time to do a similar job on KAddressBook please?

16:17, 12 January 2011

I'll have a look at it.

05:50, 13 January 2011

You do not have permission to edit this page, for the following reason:

The action you have requested is limited to users in one of the groups: Users, Administrators, trusted, KDEDevelopers.


You can view and copy the source of this page.

Return to Thread:Talk:Translation Workflow/Problems with redirected pages/reply (3).

Thanks. I've seen the work and marked it as ready for translation. The problem with the multiple colons is known. Apparently when the system has to translate the wiki markup into html for display it hits this problem. Our solution is to add some indent to the style for bullets, and where more is needed a single colon can be added. Any instances of more than one colon should be cut down to a single one if really necessary, just as you have done, whenever we come across them.

Thanks for the work

14:05, 14 January 2011

The problem I was talking about is related but distinct. It concerns the Input and Output templates. With those there can't even be a single colon, since then lines other than the first end up outside of the box. If you write

{{Input|1=1. line
2. line}}

you get

1. line
2. line

but precede it with a single colon like this

:{{Input|1=1. line
2. line}}

and you get

1. line

2. line

08:25, 15 January 2011

Yes, that seems to be so. We could easily get some indent into the style for the templates, I think. Do you think it's worth while? It's relatively rare that the full width is used anyway, so I don't see that it would create too much problem.

19:12, 15 January 2011

I think that the framing and background colour makes input and output stand out nicely. On the other hand some writers seems to prefer indentation as well, and maybe it is a bit more stylish. If it can be done without causing problems, it may be a good idea.

22:43, 15 January 2011

I'll ask pipesmoker about this - he does a lot of the styling work for us.

09:46, 16 January 2011
 
 
:{{Input|1=<nowiki>1. line
2. line</nowiki>}} 

should do the job:

1. line
2. line
Pipesmoker10:17, 16 January 2011