Difference between revisions of "User:Skierpage/CD drive woes"

Jump to: navigation, search
(hmm)
 
m (Solid!: add more output)
Line 17: Line 17:
 
The problem seems to be in the Solid layer.
 
The problem seems to be in the Solid layer.
 
  % <kbd><b>solid-hardware list details</b></kbd>
 
  % <kbd><b>solid-hardware list details</b></kbd>
 +
...
 +
udi = '/org/freedesktop/UDisks/devices/sr0'
 +
  parent = '/org/freedesktop/UDisks'  (string)
 +
  vendor = 'HP'  (string)
 +
  product = 'HP  DVD Writer 640'  (string)
 +
  description = 'CD-RW/DVD±RW DL Drive'  (string)
 +
  Block.major = 11  (0xb)  (int)
 +
  Block.minor = 0  (0x0)  (int)
 +
  Block.device = '/dev/sr0'  (string)
 +
  StorageDrive.bus = 'Scsi'  (0x3)  (enum)
 +
  StorageDrive.driveType = 'CdromDrive'  (0x1)  (enum)
 +
  StorageDrive.removable = true  (bool)
 +
  StorageDrive.hotpluggable = false  (bool)
 +
  StorageDrive.inUse = false  (bool)
 +
  StorageDrive.size = 572993536  (0x22273000)  (qulonglong)
 +
  OpticalDrive.supportedMedia = 'Cdr|Cdrw|Dvd|Dvdr|Dvdrw|Dvdplusr|Dvdplusrw|Dvdplusdl'  (0x1df
 +
)  (flag)
 +
  OpticalDrive.readSpeed = 0  (0x0)  (int)
 +
  OpticalDrive.writeSpeed = 0  (0x0)  (int)
 +
  OpticalDrive.writeSpeeds = {} (int list)
 +
 
  udi = '/org/freedesktop/UDisks/devices/sr0:media'
 
  udi = '/org/freedesktop/UDisks/devices/sr0:media'
 
   parent = '/org/freedesktop/UDisks/devices/sr0'  (string)
 
   parent = '/org/freedesktop/UDisks/devices/sr0'  (string)

Revision as of 22:16, 16 August 2011

Kubuntu 11.04 was working fine in one AMD64-bit PC. I swapped my hard drive into another PC, HP Pavilion a1012x, and it booted right up and everything works fine! Except... on the new PC no Device Actions trigger when I insert a data CD, music CD, or DVD into either of its CD-ROM drives.

I don't get the "Available Devices" menu of options to Open with File Manager/VLC /Dragon, and the USB icon says "No Devices Available". I have the usual rules for this in System Settings > Device Actions, but they don't fire.

Works

A music CD shows up fine in dolphin, device action "kioclient exec audiocd:/" works fine, vlc can File > Open Disk > /dev/cdrom1" fine...

Inserting a USB flash drive makes "Available Devices" appear with option to mount it.

Tried

I tried system settings -> removable devices > enable automatic mounting of removable media, didn't help

Solid!

Maybe some hardware didn't get reconfigured.

The problem seems to be in the Solid layer.

% solid-hardware list details
...
udi = '/org/freedesktop/UDisks/devices/sr0'
 parent = '/org/freedesktop/UDisks'  (string)
 vendor = 'HP'  (string)
 product = 'HP  DVD Writer 640'  (string)
 description = 'CD-RW/DVD±RW DL Drive'  (string)
 Block.major = 11  (0xb)  (int)
 Block.minor = 0  (0x0)  (int)
 Block.device = '/dev/sr0'  (string)
 StorageDrive.bus = 'Scsi'  (0x3)  (enum)
 StorageDrive.driveType = 'CdromDrive'  (0x1)  (enum)
 StorageDrive.removable = true  (bool)
 StorageDrive.hotpluggable = false  (bool)
 StorageDrive.inUse = false  (bool)
 StorageDrive.size = 572993536  (0x22273000)  (qulonglong)
 OpticalDrive.supportedMedia = 'Cdr|Cdrw|Dvd|Dvdr|Dvdrw|Dvdplusr|Dvdplusrw|Dvdplusdl'  (0x1df

) (flag)

 OpticalDrive.readSpeed = 0  (0x0)  (int)
 OpticalDrive.writeSpeed = 0  (0x0)  (int)
 OpticalDrive.writeSpeeds = {} (int list)
udi = '/org/freedesktop/UDisks/devices/sr0:media'
 parent = '/org/freedesktop/UDisks/devices/sr0'  (string)
 vendor = 'HP'  (string)
 product = 'HP  DVD Writer 640'  (string)
 description = 'CD-ROM'  (string)
 Block.major = 11  (0xb)  (int)
 Block.minor = 0  (0x0)  (int)
 Block.device = '/dev/sr0'  (string)
 StorageVolume.ignored = true  (bool)
 StorageVolume.usage = 'Other'  (0x0)  (enum)
 StorageVolume.fsType =   (string)
 StorageVolume.label =   (string)
 StorageVolume.uuid =   (string)
 StorageVolume.size = 572993536  (0x22273000)  (qulonglong)
 OpticalDisc.availableContent = 'Audio|Data'  (0x3)  (flag)
 OpticalDisc.discType = 'CdRom'  (0x0)  (enum)
 OpticalDisc.appendable = false  (bool)
 OpticalDisc.blank = false  (bool)
 OpticalDisc.rewritable = false  (bool)
 OpticalDisc.capacity = 572993536  (0x22273000)  (qulonglong)

Solid knows there's an Audio Optical Disc plugged in, but it's ignored, and the System Settings > Device Actions rules include "The devices Ignored must equal false".

How do I tell Solid not to ignore the storage volume?!

Bug

This sounds similar to Launchpad bug 709868 "kde 4.6 device actions broken".

He has the StorageVolume.ignored = true. He comments

Ok... experimented a bit about how solid-hardware works and found what the latest problem is
One needs to create /media/cdrom0 by hand.
Solid does not manage mount points automatically creating dirs in media at need
Solid does not anymore mount by label... namely should have mounted as /media/CDSTOMPER35 but mounts as /media/cdrom0

But I have a /media/cdrom symlinks to /media/cdrom0 , so that's not it.


Other

System Settings > Multimedia > Audio CDs > General > Specify CD Device is /dev/cdrom. I don't have this, I have /dev/cdrom1 and /dev/cdrom2. Should I change this or is it another bug that this is wrong?


Content is available under Creative Commons License SA 4.0 unless otherwise noted.