User talk:Yurchor

Jump to: navigation, search

Contents

Thread titleRepliesLast modified
The Dolphin edit010:56, 6 October 2010
Plasma/FAQ919:33, 30 September 2010
Amarok pages111:14, 26 September 2010
"Chatty" pages - hard to mark up 311:31, 23 September 2010
Chihuahua012:56, 6 September 2010
UserBase problem discussion016:49, 28 June 2010
Russian Translator016:46, 28 June 2010
First page
First page
Next page
Next page
Last page
Last page

The Dolphin edit

I have plastered warnings all over about not touching the tags, but still people edit without reading them :-( Thanks for rescuing things after this edit. I wish there was some way of making the tags untouchable, but I can't think of anything.

annew10:56, 6 October 2010

Plasma/FAQ

Plasma/FAQ is a redirect which always points to the latest version, so it's best not to use the link with the version number.

annew14:57, 29 September 2010

Sure. So, what to do if user is on 4.4 (4.3, 4.5 soon (hey, Plasma developers, where are you?), etc.) and wants to be instructed how to add a widget on his panel? ;)

Yurchor15:05, 29 September 2010

On every Plasma/FAQ/whatever page there is an info box directing to the earlier versions :-)

annew15:22, 29 September 2010
 

Not really... :-)

Yurchor15:29, 29 September 2010

Yes, really. 4.4 says For older versions you can turn to the KDE 4.3 specific page, theKDE 4.2 specific page, the KDE 4.1 specific page or the KDE 4.0 one

4.3 says For older versions you can turn to the KDE 4.2 specific page, KDE 4.1 specific page or the KDE 4.0 one

and so on. And they are all links.

annew17:19, 29 September 2010
 

The only page with these links is Plasma/FAQ. Aliasing of Plasma/FAQ with Plasma/FAQ/4.4 (4.3, 4.5, etc.) breaks all links on the translated versions (via Special:myLanguage). Subpages, like Plasma/FAQ/4.4/Configuration, have no aliases at all.

What is the solution for linking if we not use "/4.x/" in links? ;)

Yurchor17:30, 29 September 2010

I'm not sure that I'm understanding the problem but while looking at it, I did note that the Plasma/FAQ/4.4 (which is what the user is actually reading) didn't have Special:myLanguage at all, so I've fixed that.

Plasma/FAQ itself only contains the redirect to the latest version, and the redirect has to be changed when a new version is made. Apart from that, all the links have /4.x in them. I would have thought that between that and the myLanguage thing it would work. If it doesn't, can you explain a bit more about what actually happens? Thanks

annew17:53, 29 September 2010
 

Consider the following examples: 1. Plasma/FAQ#How does Plasma work? links to the English page.

Special:MyLanguage/Plasma/FAQ#How does Plasma work? in any locale you will also be linked to the English page (broken localized links).

2. Plasma/FAQ/4.4/Configuration is valid page that can be linked, e.g. Plasma/FAQ/4.4/Configuration#Can_I_move_the_applets_on_the_panel.3F

On the other hand

Plasma/FAQ/Configuration#Can_I_move_the_applets_on_the_panel.3F points to nowhere (broken subpages).

:'(
Yurchor18:06, 29 September 2010

Plasma/FAQ has only one purpose - to direct anyone searching to the latest version. It doesn't have any content, any sections, any subpages, so I'm surprised that even your first example works. I wouldn't have expected any links to be formulated against Plasma/FAQ at all - but against the versioned links (after all, the reader doesn't actually see that part of the link anyway). Now at last I understand where we started from :-) Yes, you are correct, I made a mistake there. Sorry about that, but I really did need to understand what you were pointing out.

annew18:27, 29 September 2010
 
 
 
 
 

Amarok pages

I did not do the original markup and I'd never looked at these pages. It looks as though they were done at the time that Siebrand thought we should tie down the translation to the nth degree. I've edited Amarok/QuickStartGuide, which should fix both your problem with images and my problem with section editing not working. Please let me know asap if it's now OK - if so I'll carry on with the others. If you want any other changes, I can do those at the same time.

annew10:59, 26 September 2010

Much better for me now, but... (oh, those curses from the other translators... Face-smile.png)

Yurchor11:14, 26 September 2010
 

"Chatty" pages - hard to mark up

Some pages have a chatty style that is difficult to mark up. Sometimes I am marking features as menuchoices, when they are not exactly so. I don't know whether this is the best approach, or not, so I'd appreciate advice. Examples of such are the KOffice pages, KWord, KSpread, KPresenter etc..

annew10:52, 22 September 2010

imho, these pages are by no means documentation, rather advertisement pages. Hence, there is no sense to use the same markup. Much more easily to use common wiki markup (quotes for emphasis, bold, etc.) for these pages.

Yurchor11:14, 22 September 2010

OK, I'll go through the KOffice pages and change those. If you meet similar inappropriate stuff, please change them and accept my apologies for the extra work.

Your description "rather advertisement pages" is, of course, exactly what they were in the first place, when UserBase was conceived as a showcase for apps, rather than as a place for documentation.

annew11:18, 22 September 2010

A discussion which started from the same place: Talk:Translation_Workflow#Use_of_menuchoice_tag_421. I'd like your input, please.

annew11:31, 23 September 2010
 
 
 

We are close to moving UserBase to the new Chihuahua theme. There are some big advantages with Chihuahua, not the least being the ability to adapt to screen space, both large screens and small, hand-held ones. Much of the work I've been doing lately has been to prepare pages for the switch. As always, with something new, there are likely to be issues that we are not aware of until it is in more general use, so I'm approaching all who have made significant contribution in the last seven days, asking for help.

I'd like you to change your User Preferences to use Chihuahua, as soon as possible. The plan at the moment is that if at the end of this week we have no show-stopper issues we will make Chihuahua the default theme for UserBase, probably next weekend.

There is a public Etherpad at http://webteam.notes.kde.jefferai.org/14? - please add any notes, comments, issues there. It's also helpful if you say "Hi" in the chat window, because that ties a comment colour to your name, so I know who to approach if more discussion is needed.

Thanks for the help.

annew12:56, 6 September 2010

UserBase problem discussion

Siebrand fixed markup on Applications/ and similar catalogue pages. They are now correct, but have caused a lot of work. I think it's avoidable, and doesn't pay off enough. Could you please join the discussion on http://userbase.kde.org/Talk:Translation_Workflow where I'm just about to add my reasoning. Your perspective would be valuable.

annew16:49, 28 June 2010

Russian Translator

Julia Vladimirov, username Julia, has asked to be added to Translators to help with Russian translation. I've added her to the group and asked her to contact you. --annew 14:33, 28 June 2010 (CEST)

annew16:46, 28 June 2010
First page
First page
Next page
Next page
Last page
Last page

This page was last modified on 28 June 2010, at 16:46. Content is available under Creative Commons License SA 4.0 unless otherwise noted.