Krita/Manual/WorkingWithImages

Jump to: navigation, search

Computers work with files and as a painting program, Krita works with images as the type of file it creates and manipulates.

What do Images Contain?

If you have a text document, it of course contains letters, strung in the right order, so the computer loads them as coherent sentences.

Raster Data

This is the main data on the paint layers you make. So these are the strokes with the paint brush and look pixely up close. A multi-layer file will contain several of such layers, that get overlaid on top of each other so make the final image.

A single layer file will usually only contain raster data.

Vector Data

These are mathematical operations that tell the computer to draw pixels on a spot. This makes them much more scalable, because you just tell the operation to make the coordinates 4 times bigger to scale it up. Due to this vector data is much more editable, lighter, but at the same time it's also much more CPU intensive.

Operation Data

Stuff like the filter layers, that tells Krita to change the colors of a layer, but also transparency masks, group layer and transformation masks are saved to multi-layer files. Being able to load these depend on the software that initially made the file. So Krita can load and save groups, transparency masks and layer effects from PSD, but not load or save transform masks.

Meta Data

Meta Data is information like the creation date, author, description and also information like DPI.

Image size

The image size is the dimension and resolution of the canvas. Image size has direct effect file size of the Krita document. The more pixels that need to be remembered and the higher the bit depth of the color, the heavier the resulting file will be.

DPI/PPI

DPI stands for Dots per Inch, PPI stands for Pixels per Inch. In printing industry, suppose if your printer prints at 300 DPI It means it is actually putting 300 dots of colors in an area equal to an Inch. This is really important for artists, This means the number of pixels your artwork has in a relative area of an Inch.

DPI is the concern of the printer, and artists while creating artwork should keep PPI in mind. according to the PPI you have set the printers decide how large your image should be on a piece of paper.

Some standards:

72 PPI
This is the default PPI of monitors as assumed by all programs. It is not fully correct, as most monitors these days have 125 PPI or even 300 PPI for the retina devices. None the less, when making an image for computer consumption, this is the default.
120 PPI
This is often used as standard for low-quality posters.
300 PPI
This is the minimum you should use for quality prints.
600 PPI
The quality used for line-art for comics.

Color depth

We went over color depth in the Color Management page. What you need to understand is that Krita has image color spaces, and layer color spaces, the latter which can save memory if used right. For example, having a lineart layer in greyscale can half the memory costs.

Image color space vs layer color space vs conversion.

Because there's a difference between image color space and layer color space, you can change only the image colour space in image->properties which will leave the layers alone. But if you want to change the color space of the file including all the layers you can do it by going to image->convert image color space this will will convert all the layers colorspace as well.

Author and Description

Krita will automatically save who created the image into your image's metadata.

Document Infomration.PNG

You can edit these things in File->Document Information, and for the author's information settings->configure Krita->author information. You can switch between profiles under settings->Active author profile.

Setting the canvas background color

You can set the canvas background color via Image->Image Background color and transparency. This allows you to turn the background colour non-transparent and to change the color. Also useful for certain file formats which force a background color instead of transparency. PNG and JPG export use this color as the default color to fill in transparency if you do not want to export transparency.

If you come in from a program like Paint Tool Sai, then using this option, or using set canvas background color in the new file options, will allow you to work in a slightly more comfortable environment, where transparency isn't depicted with checkered boxes.

Basic transforms

There's some basic transforms available in the image menu.

Shear Image
This will allow you to skew the whole image and it's layers.
Rotate
This will allow you to rotate the image and all it's layers quickly.
Mirror Horizontal/Vertical
This will allow you to mirror the whole image with all it's layers.

But there's more options than that...

Cropping and resizing the canvas

You can crop and image with the crop-tool, to cut away extra space and improve the composition.

Trimming

Using image->trim to layer, Krita resizes the image to the dimensions of the layer selected. Useful for when you paste a too large image into the layer and want to resize the canvas to the extent of this layer.

Image->trim to selection is a faster cousin to the crop tool, This helps us to resize the canvas to the dimension of any active selection. This is especially useful with right clicking the layer on the layer stack and choosing select opaque. Image->trim to selection will then crop the canvas to the selection bounding box.

Image->trim to image size is actually for layers, and will trim all layers to the size of the image, making your files lighter by getting rid of invisible data.

Resizing the canvas

You can also resize the canvas via image->resize canvas(or CTRL+ALT+C). The dialog box is shown below.

Resize Canvas.PNG In this, constraint proportions will make sure the height and width stay in proportion to each other as you change them. Offset makes indicates where the new canvas space is added around the current image. You basically decide where the current image goes(if you press the left-button, it'll go to the center left, and the new canvas space will be added to the right of the image).

Another way to resize the canvas according to the need while drawing is when you scroll away from the end of the canvas, you can see an arrow appear. Clicking this will extend the canvas in that direction. You can see the arrow marked in red in the example below

Infinite-canvas.jpg

Resizing the image

Scale Image to New Size allows you to resize the whole image. Also, importantly, this is where you can change the resolution or upres your image. So for instance, if you were initially working at 72 PPI to block in large shapes and colors, images, etc.. and now you want to really get in a do some detail work at 300 or 400 PPI this is where you would make the change.

Like all other dialogs where a chain link appears, when the chain is linked the aspect ration is maintained. To unlink the chain, just click on the links and the two halves will separate.

Scale Image to New Size.PNG

Separating Images.

This powerful image manipulation feature lets you separate an image into its different components or channels.

Separate Image.PNG

This is useful for people working in print, or people manipulating game textures. There's no combine functionality, but what you can do, if using colored output, is to set two of the channels to the addition blending mode.

For greyscale images in the RGB space, you can use the copy red, copy green and copy blue blending modes, with using the red one for the red channel image, etc.

Saving, exporting and opening

when Krita creates or opens a file, it has a copy of the file in memory, that it edits. This is part of the way how computers work: They make a copy of their file in the ram.

Thus, when saving, Krita takes it's copy and copies it over the existing file.

There's a couple of tricks you can do with saving.

Save
Krita saves the current image in it's memory to a defined place on the hard-drive. If the image hadn't been saved before, Krita will ask you where to save it.
Save As
Make a copy of your current file by saving it with a different name. Krita will switch to the newly made file as it's active document.
Open
Open a saved file. Fairly straightforward.
Export
Save a file to a new location without actively opening it. Useful for when you are working on a layered file, but only need to save a flattened version of it to a certain location.
Open Existing Document As Untitled Document
This is a bit of an odd one, but it opens a file, and forgets where you saved it to, so that when pressing 'save' it asks you where to save it. Also called 'import' in other programs.
Create Copy from Current Image
Makes a new copy of the current image. Similar to Open Existing Document As Untitled Document, but then with already opened files.
Save Incremental Version
Saves the current image as 'filename'_XXX.kra and switches the current document to it.
Save Incremental Backup.
Exports the current image as 'filename'_XXX.kra.


Ktip.png
 
Tip
Since Krita's file format is compressed data file, in case of corrupt or broken file you can open it with archive managers and extract the contents of the layers. This will help you to recover as much as possible data from the file. On windows you need to rename it to filename.zip to open it.


Saving for the web

Krita's default saving format is the *.kra format. This format saves everything Krita can manipulate about an image: Layers, Filters, Assistants, Masks, Color spaces, etc. However, that's a lot of data, so *.kra files are pretty big. This doesn't make them very good for uploading to the internet. Imagine how many people's data-plans hit the limit if they only could look at *.kra files! So instead, we optimise our images for the web.

There's a few steps involved:

  1. Save as a .kra. This is your working file and serves as a backup if you make any mistakes.
  2. Flatten all layers. This turns all your layers into a single one. Just go to Layer->Flatten Image or press Ctrl+Shift+E. Flattening can take a while, so if you have a big image, don't be scared if Krita freezes for a few seconds. It'll become responsive soon enough.
  3. Convert the color space to 8bit sRGB(if it isn't yet). This is important to lower the filesize, and PNG for example can't take higher than 16bit. Image->Convert Image Color Space and set the options to RGB, 8bit and sRGB-elle-v2-srgbtrc.icc respectively. If you are coming from a linear space, uncheck little CMS optimisations
  4. Resize! Go to image->scale image to new size or use Ctrl+Alt+I. This calls up the resize menu. A good rule of thumb for resizing is that you try to get both sizes to be less than 1200 pixels. (This being the size of HD formats). You can easily get there by setting the Resolution under Print Pize to 72 dots per inch. Then press OK to have everything resized.
  5. Save as a web-safe image format. There's several:
JPG
Use this for images with a lot of different colors, like paintings.
PNG
Use this for images with few colours or which are black and white, like comics and pixel-art. Select 'save indexed if possible' to optimise even more.
WebP
Supossedly useful for both paintings and lower color iamges like comics, but it's not supported by most social media yet.
GIF
Only use this for animation(will be supported this year) or images with a super low color count, because they will get indexed.

Save your image, upload, and show it off!

Templates and Workflow

Krita New File Template A.PNG

Templates are just *.kra files which are saved in a special location so it can be pulled up by Krita quickly. This is like the 'Open Existing Document and Untitled Document' but then with a nicer place in the UI.

You can make your own template file from any *.kra file, by using create template from image in the file menu. This will add your current document as a new template, including all its properties along with the layers and layer contents.

We have the following defaults:

Comic Templates

These templates are specifically designed for you to just get started with drawing comics. The comic template relies on a system of vectors and clones of those vector layers which automatically reflect any changes made to the vector layers. In between these two, you can draw your picture, and not fear them drawing over the panel. Use Inherit Alpha to clip the drawing by the panel.

European Bande Desinée Template.
This one is reminiscent of the system used by for example TinTin or Spirou et Fantasio. These panels focus on wide images, and horizontal cuts.
US-style comics Template.
This one is reminiscent of of old DC and Marvel comics, such as Batman or Captain America. Nine images for quick story progression.
Manga Template.
This one is based on Japanese comics, and focuses on a thin vertical gutter and a thick horizontal gutter, ensuring that the reader finished the previous row before heading to the next.
Waffle Iron Grid
12 little panels at you disposal.

Design Templates

These are templates for design and have various defaults with proper ppi at your disposal:

  • Cinema 16:10
  • Cinema 2.93:1
  • Presentation A3-landscape
  • Presentation A4 portrait.
  • Screen 4:3
  • Web Design

DSLR templates

These have some default size for photos

  • Canon 55D
  • Canon 5DMK3
  • Nikon D3000
  • Nikon D5000
  • Nikon D7000

Texture Templates.

These are for making 3D textures, and are between 1024, to 4092.


This page was last modified on 22 September 2015, at 19:14. Content is available under Creative Commons License SA 4.0 unless otherwise noted.