Difference between revisions of "Kdenlive/Manual/Installation/fr"

Jump to: navigation, search
(Created page with "Ces fichiers d'installation sont hébergés à http://files.kde.org/kdenlive/ où vous trouverez un dossier pour les sorties (releases) et un dossier pour les instables (unsta...")
(Created page with "Le développement de ''Kdenlive''' a désormés commuté sur une nouvelle version de KDE Frameworks appelée KF5 (KDE Frameworks 5). Pour installer les versions de '''Kdenlive...")
Line 24: Line 24:
 
En juin 2015, [https://launchpad.net/~sunab/+archive/ubuntu/kdenlive-release-old ce] PPA inclut la version 0.9.10 de '''Kdenlive''' , 1.4.0 de Frei0r et 0.9.3 de melt.
 
En juin 2015, [https://launchpad.net/~sunab/+archive/ubuntu/kdenlive-release-old ce] PPA inclut la version 0.9.10 de '''Kdenlive''' , 1.4.0 de Frei0r et 0.9.3 de melt.
  
Development of '''Kdenlive''' has now switched to a new version of the KDE Frameworks called KF5 (KDE Frameworks 5). To install versions of '''Kdenlive''' using this underlying technology, you need to be on a Linux distribution which supports KF5. Ubuntu and its derivatives versioned 15.04 and higher support KF5.   It is not possible to install KF5 on distributions earlier than 15.04 (except by ''chroot''ing your system).
+
Le développement de ''Kdenlive''' a désormés commuté sur une nouvelle version de KDE Frameworks appelée KF5 (KDE Frameworks 5). Pour installer les versions de '''Kdenlive''' utilisant cette technologie sous-jacente, vous devez être sur une distribution de Linux qui soutient KF5. Ubuntu et ses dérivées version 15.04 et suivantes soutiennent KF5. Il n'est pas possible d'installer KF5 sur des distributions précédentes à la 15.04 (excepté en "chroot"ant votre système).
Versions using KF5 are distributed by the [https://launchpad.net/~kubuntu-ci Kubuntu-CI Team]. The sunab ppa (see below) now also distributes KF5 versions. <br />
+
Les versions utilisant KF5 sont distribuées par [https://launchpad.net/~kubuntu-ci l'équipe Kubuntu-CI]. Le ppa sunab (voir ci-dessous) distribue maintenant aussi les versions KF5. <br /> Les numéros de version employant KF5 commencent à partir de 15.04.0. Br/> Cet auteur recommande d'utiliser le ppa sunab pour installer Kdenlive plutôt que celui de l'équipe Kubuntu-CI parce que le ppa de l'équipe de Kubuntu-CI a beaucoup d'autres paquets inclus, ce qui engendrera beaucoup de mises à jour dans votre système &mdash;avec le risque potentiel de le casser.<br />
Version numbers of the KF5 flavour start at 15.04.0. <br />
 
This author recommends using the  sunab ppa to install Kdenlive rather than the  Kubuntu-CI Team because the Kubuntu-CI Team PPA has many other packages in it which will attempt to uprade all sorts of things on your system&mdash;with the potential of breaking it.<br />
 
  
 
==== Debian ====
 
==== Debian ====

Revision as of 04:04, 18 October 2018

Other languages:
Deutsch • ‎English • ‎dansk • ‎español • ‎français • ‎português do Brasil • ‎русский • ‎українська • ‎中文(台灣)‎

Installation

Les informations de cette page peuvent être intéressantes pour des raisons historiques toutefois vous devriez visiter la page téléchargement du site Web Kdenlive pour lire des informations à jour concernant l'installation de Kdenlive (Août 2017).

Installation de paquetages binaires

La plupart des distributions Linux fournissent des paquetages binaires récents de Kdenlive et pouvant être installés par votre gestionnaire d'installation. Bien que dans quelques cas vous pourriez trouver des versions plus récentes dans les répertoires privés.

Cette page à l'accueil de Kdenlive comporte les instructions sur la manière de choisir les fichiers source pour ces dernières versions, en fonction de quelle type de Linux vous exécutez. Les instructions pour Debian, Fedora, Gentoo, OpenSUSE, Slackware et Ubuntu sont disponibles.


En mai 2015, obtenir et installer la dernière version de Kdenlive est devenu un peu compliqué. Le développement de Kdenlive jusqu'à ce moment utilisait une technologie appelée KDE Frameworks 4. Et la dernière version stable qui utilise cette technologie est la version 0.9.10, diffusée le 25 septembre 2014.
Pour l'utiliser, vous devez avoir des versions récentes de frei0r, Kdenlive , mlt et libvidstab, par exemple :

  • frei0r = 1.4.0+git20140826.72e51041
  • Kdenlive = 0.9.10
  • mlt = 0.9.3+git20141005.22abed67
  • libvidstab=2:0.98b


En juin 2015, ce PPA inclut la version 0.9.10 de Kdenlive , 1.4.0 de Frei0r et 0.9.3 de melt.

Le développement de Kdenlive' a désormés commuté sur une nouvelle version de KDE Frameworks appelée KF5 (KDE Frameworks 5). Pour installer les versions de Kdenlive utilisant cette technologie sous-jacente, vous devez être sur une distribution de Linux qui soutient KF5. Ubuntu et ses dérivées version 15.04 et suivantes soutiennent KF5. Il n'est pas possible d'installer KF5 sur des distributions précédentes à la 15.04 (excepté en "chroot"ant votre système). Les versions utilisant KF5 sont distribuées par l'équipe Kubuntu-CI. Le ppa sunab (voir ci-dessous) distribue maintenant aussi les versions KF5.
Les numéros de version employant KF5 commencent à partir de 15.04.0. Br/> Cet auteur recommande d'utiliser le ppa sunab pour installer Kdenlive plutôt que celui de l'équipe Kubuntu-CI parce que le ppa de l'équipe de Kubuntu-CI a beaucoup d'autres paquets inclus, ce qui engendrera beaucoup de mises à jour dans votre système —avec le risque potentiel de le casser.

Debian

Le projet Debian inclut les paquets Kdenlive depuis la version "condensée" (6.0) . Néanmoins, pour bénéficier des mises à jour récentes et des corrections, you pouvez essayer de mettre à jour à partir d'une version de "test" ou même "sid".

Dès que votre outil de gestion des paquets pointe sur une version appropriée, un simple apt install kdenlive devrait suffire.

Le PPA de Sunab (voir ci-dessous) n'est pas recommandé pour Debian car Debian utilise une structure de librairie différente pour l'architecture multiple (référence: ce billet de vpinon).

Ubuntu et ses dérivés

Ubuntu également offre Kdenlive depuis "gutsy" (7.10). Néanmoins, pour bénéficier des mises à jour récentes et de la correction des bogues, vous devriez mettre à jour avec la dernière version.

ppa:kdenlive/kdenlive-master est la branche de développement avec les toutes dernières fonctionalités.

ppa:kdenlive/kdenlive-testing est la branche dédiée à une fonctionalité, et qui commence avec la première version bêta, avec les mises à jours concernant les corrections de bogues au fur et à mesure que les solutions sont trouvées

ppa:kdenlive/kdenlive-stable est la dernière version robuste officielle

Les paquets du ppa ne sont pas tous nécessaires. Installez ou mettez à jour ce qui suit pour obtenir la version 15.04 (numérotation des version du 13 juillet 2015)

  • kdenlive (15.04.2-0ubuntu0-~sunab~vivid4)
  • kdenlive-data (15.04.2-0ubuntu0-~sunab~vivid4)
  • libmlt++3 (0.9.6-0ubuntu0~sunab~vivid1)
  • libmlt-data (0.9.6-0ubuntu0~sunab~vivid1)
  • libmlt6 (0.9.6-0ubuntu0~sunab~vivid1)
  • libvidstab1.0 (2:0.98b-0ubuntu0~sunab~vivid1)
  • melt ( 0.9.6-0ubuntu0~sunab~vivid1)

Les utilisateurs non-Kubuntu devront installer le paquet kde-runtime pour corriger l'absence de boutons et d'icônes.

Fedora, RedHat et leurs dérivés

RPM packages are not yet maintained in an official branch, so you must go through an unofficial repository such as RPM Fusion or packman (Has ver 15.12.0 29 Dec 2015). Follow the site's recommendations to make them available and end with yum install kdenlive.

Portages Gentoo, Arch, BSD

Les scripts de construction sont disponibles pour les systèmes à jour, aussi exécutez respectivement emerge kdenlive ou pacman -S kdenlive ou pkg_add kdenlive, etc.

Windows

La première version Windows de Kdenlive (v16.12.1) est disponible au téléchargement ici. Lisez les instructions d'installation pour Windows.

Vous pouver également essayer et utiliser une distribution Linux virtualisée pour exécuter Kdenlive sous Windows. Vous trouverez une liste de conseils sur cette page.

Il existe aussi le projet kdenlive on win sur SourceForge qui consiste en une image VirtualBox Ubuntu qui est préconfigurée pour exécuter Kdenlive". Le projet été mis à jour dernièrement le 9 août 2012.

MacOS

Kdenlive et MLT peuvent se compiler et s'exécuter sous Mac OS X. Les paquets sont disponibles dans le projet MacPorts .

MacPorts is a source-based system — there is not a binary app bundle for Kdenlive. Therefore, Kdenlive and all of its numerous dependencies, including multimedia libraries, KDE, and Qt, must be compiled. This can take a long time and much disk space! Furthermore, it is not unusual for something not to build correctly; it is definitely not something for the novice, impatient, or "faint of heart".

You may have some success getting support for the MacPort of Kdenlive on the Mac Ports forum on MacOS Forge.

Installation à partir des sources

If you want to test latest committed code or your personal patches, you will have to build Kdenlive (and probably MLT) on your own.

Les détails sur la manière de compiler et d'installer Kdenlive à partir des sources, sont disponibles sur le wiki de la Communauté.

You can use your distribution's package building procedure to use its software management system to install/upgrade/remove the binaries and data, and eventually share your builds (and even contribute to package maintenance - refer to the respective distribution manual).

If you prefer you can build & install Kdenlive to a local area (preferably not /usr, but rather /usr/local or $HOME/my_local_builds/kdenlive-last-release or similar). You could try using this build script to build the latest version from the sources. Or you could use the this build script to build kdenlive ver 0.9.10 [1] (Follow the instructions under "show kdenlive". These instructions will build Kdenlive and its dependancies [e.g. melt, ffmpeg] in a "sandbox").

Installation à partir des paquetages binaires précompilés

Kdenlive offre maintenant des paquets binaires précompilés déployés en utilisant la technologie Appimage - voir la section Appimage sur la page de téléchargement du site web Kdenlive.

Ces fichiers d'installation sont hébergés à http://files.kde.org/kdenlive/ où vous trouverez un dossier pour les sorties (releases) et un dossier pour les instables (unstable). Le dossier release contient le fichier binaire construit de la version stable actuelle de Kdenlive.

Les versions Windows sont dans le format d'archives 7zip avec les noms de fichiers dans la forme

Kdenlive-17.04.0-2-w64.7z

Pour lire des instructions d'installation concernant Windows veuillez voir la page de téléchargement.


Les versions de Linux Appimage sont les fichiers dont le nom est de la forme

Kdenlive-17.04.1b-x86_64.AppImage

Pour exécuter les versions AppImage il suffit de rendre exécutable le fichier téléchargé (chmod +x) puis l'exécuter (./Kdenlive-17.04.1b-x86_64.AppImage)

Les paquetages binaires pré-construits (pre-built) sont souvent une solution facile si vous avez du mal avec votre installation, et peuvent être préférables à la construction par vous-même parce que cela vous évite d'avoir à installer un environnement de construction.

La version pré-construite AppImage et votre version principale de Kdenlive peuvent vivre simultanément sur votre machine afin que vous puissiez tester de nouvelles versions, supposément instables, sans casser la version principale de Kdenlive située sur votre système.


Un inconvénient est que ces paquetages ont été construits avec une version de ffmpeg qui emploie seulement les codecs vidéo libres. Le type de fichiers vers lequel vous pouvez rendre votre vidéo est donc limité. Choisir le profil Theora dans la destination de rendu Sites Web fonctionne.

Les fichiers binaires Kdenlive pré construits soutiennent actuellement seulement les systèmes d'exploitation 64 bits.

  1. on distributions older than Debian 6 or Ubuntu 10.04 and derivatives, you need to set ENABLE_SWFDEC=0 in the config variables of the script. Modify the INSTALL_DIR in the script to something like INSTALL_DIR="$HOME/my_local_builds/kdenlive-last-release" to make it match where you want this local build to install.

Content is available under Creative Commons License SA 4.0 unless otherwise noted.