KPhotoAlbum Video Support

Jump to: navigation, search
Other languages:
català • ‎dansk • ‎English • ‎日本語 • ‎українська

KPhotoAlbum has support for categorizing videos along with its usual support for categorizing images. Getting KPhotoAlbum to show thumbnails for videos and actually showing the videos can be tricky. This page will give you some hints. For sound, KPhotoAlbum uses Phonon. It is possible to change the Phonon backend, but it is usually better to stick with the backend that your distro has configured.


Building Thumbnail Support

KDE has packages for generating the thumbnails for videos. If the correct packages are installed then you should see the thumbnails. KPhotoAlbum uses mplayerthumbs, so you must have this package installed.

Note-box-icon.png
 
Note
The entry for your distribution may be considerably out of date. If you are able to add newer information that is a great help to other users.


Below is a list of packages required for different distributions:

Kubuntu/Ubuntu:

Note-box-icon.png
 
Note
Ubuntu is a Debian which has been slightly modified (apt-get for example, is the killer-app coming from Debian). So maybe try the Debian advice below if you can't see videos on your system.


In Ubuntu 10.04 the package phonon-backend-xine along with libxine1-all-plugins appears to be working.

With Ubuntu 10.10 it is worth trying phonon-backend-gstreamer if the video is not good.

Naturally appropriate codecs must also be installed.

Debian:

Required:

  • libarts1-xine
  • kmplayer-plugin


Showing Videos

KPhotoAlbum will show the videos in the viewer if the right support packages are installed (Again KPhotoAlbum doesn't do the real work of showing the videos, but relies on the KDE subsystem to do so). Below you can see which package are needed for your system:

(K)Ubuntu

See Setting up Restricted formats


Still Doesn't Play Videos?

If you believe you have all the right packages installed, and it still doesn't play videos, then it is time to check your KDE configuration.

Open up Konqueror, choose Settings -> Configure Konqueror -> File Associations tab. Open up the Video branch, and choose the item you can't get working (e.g mpeg). The screen now shows a tab widget for configuring that item. First check that the extension you have in mind is listed in the Filename Patterns.


Kphotoalbum fileformat.jpg


Next choose the Embedding tab, and check that it shows any services in the "Service Preference Order" listbox.

Kphotoalbum embedding.jpg

What Do the Errors Really Mean?

One way to get to this page is from trying to play a video, with the result that KPhotoAlbum shows you an error box with the different actions it tried before failing. Here is a list of the possible failures:

  • Finding mime type
  • Getting a KPart for the mime type
  • Getting a library for the part
  • Instantiating Part
  • Fetching Widget from part

If any of these fails it is very likely that you need to go back up and look carefully at the settings in the previous section. If you see one of these fail, and fix it. Please add a bit of description above to help other users.


This page was last modified on 13 October 2010, at 15:57. Content is available under Creative Commons License SA 4.0 unless otherwise noted.