Kdenlive/Manual/Projects and Files/Clips

Jump to: navigation, search
Other languages:
dansk • ‎English • ‎русский • ‎українська • ‎中文(台灣)‎

Clips

See also Clip Menu.

Clips (Video, Audio and Images)

The Kdenlive Add clip icon.png button (Add Clip) brings up the Add Clip Dialog where you can choose video, audio or still image clips to add to the Project Bin.

Add clip dialog.png

The button Kdenlive file Preview buttons.png labeled 1 toggles File Preview on and off (applies to image files only). The slider labeled 2 adjusts the size of the preview icons. The Import image sequence checkbox labeled 3 enables the import of a series of images that can be used to make a stop motion animation. The Transparent background for images checkbox labeled 4 makes the process respect an alpha channel in the source images ref.

You can add other types of clips by choosing a clip type from the menu brought up from the drop down button next to the Kdenlive Add clip icon.png button.

Kdenlive Add other clip types.png

Color clips

Color clips are images composed of a single color that can be added to the Project Tree. They can be useful to provide a background on which to place titles.

Add color clips by choosing Add Color Clip from the drop down button next to the Icon-hi16-action-kdenlive-add-clip.png button.

This brings up the Color Clip dialog from which you can choose a color and a duration.

Add color clip.png

Clicking OK adds the clip to the project tree. The clip can then be dragged to the timeline. The duration of the color clip can be adjusted on the timeline.

Title clips

See Titles

Slideshow clips

Slideshow clips are clips created from a series of still images. The feature can be used to make an animation from a collection of still images or to create a slideshow of still images. To create the former, use a short frame duration; to create the latter, use a long frame duration.

To create a slideshow clip, choose Add Slide Show Clip from the Add Clip drop down list.

Create slide show clip.png

From the Slideshow Clip dialog choose Filename pattern as Image selection method.

Browse to the location of the images which will make up your slideshow and select the first image. The subsequent images that are to be used in the slide show will be selected based on some sort of filename algorithm that predicts what the next image file name should be.

For example, if the first image is 100_1697.jpg then the next will be 100_1698.jpg, etc.

Select an appropriate frame duration — this defines how long each image be dispayed.

Then hit OK. A video file made up of all the images in the folder from which you selected the first frame file from will be added to the Project Tree.

You can then drag this video to the timeline.

Center crop: automatically fills the output video frame with the images while maintaining their aspect ratio by cropping equal amounts from each edge. Said another way, it removes the black bars that will appear when the photo orientation or aspect does not match the video's.

Animation: adds preset slow smooth pan and zoom effects also known as the Ken Burns Effect. You can choose no animation, pans only, zooms only, or a combination of pans and zooms. Each option also has a low pass filter to reduce the noise in the images that may occur during this operation. Low pass filtering is much slower, so you should preview without it, and then enable it to render.

Create Folder

see Create Folder

Online Resources

see Project Menu - Online Resources


Stop Motion

See Stop Motion Capture

Proxy clips
Activating proxy clips

Proxy clips are one of the most useful inventions for editing if you are not working on an ultra high-end machine. Even quite well speced PCs can struggle with High Definition footage if proxy clips are not turned on. The trick that the proxy clip feature does is that the original clips are replaced by clips with lower resolution and a less complex codec. Video decoding, e.g. of H.264 clips, requires a lot of computing power and computing power is required for rendering effects in real time. If insufficient power is available, playback will stutter. Proxy clips require hardly any computing power at all, which allows fluent playback.

Proxy clips can be enabled/disabled for the current project in the Project Settings (Project -> Project Settings).

To enable proxy clips by default for new projects, go to Settings -> Configure Kdenlive -> Project Defaults -> Enable Proxy Clips. See also the Project Settings page



Proxy clip creation.png

As soon as proxy clips are enabled, they can be generated for specific project clips in the Project Tree widget via the context menu Proxy Clip. After you select Proxy Clip for a clip, a job will start to create the clip. You can view the progress of this job by looking at the little gray progress bar that appears at the bottom of the clip in the Project Tree — see picture. Clicking Proxy Clip again disables the proxy for this clip.

You can multi-select clips in the Project Tree and select Proxy Clip to start a batch proxy clip generation job which will queue up multiple proxy clip generation jobs.


Proxy clip creation completed.png

Once the proxy clip creation has completed, the proxy clip will appear with a P icon in the Project Tree.
When rendering to the final output file, you can choose whether to use the proxy clips as well. It is disabled by default , but for a quick rendering preview it is useful.


Clip Properties

You can display and edit clip properties by selecting a clip in the Project Bin and choosing Clip Properties from the Project menu or from the right-click menu. Or by turning on the display of clip properties the View > Clip Properties check box.

Video Properties

Clip properties video.png

Force Properties

The Force Properties tab displays advanced properties of the clip where you can select a check box and then force the clip to take the property you specify. For example you can use Force aspect ratio to tell a clip that seems to have forgotten it was 16:9 ratio that it really is 16:9 ratio.

Clip properties advanced.png

Advanced Clip property options are:

  • Force aspect ratio
  • Force frame rate
  • Force progressive
  • Force Field order
  • Decoding threads
  • Video index
  • Audio index
  • Force colorspace
  • Full Luma range


Markers

Clip properties Markers.png

You can use the Markers tab to add markers for certain points in the source file that are important. However, it is probably easier to add markers to your clips via the Clip Monitor because that allows you to preview the file at the location where you are adding the marker.

Once markers are put in your clip, you can access them in the Clip Monitor by right-clicking and selecting Go To Marker (see picture.) Also note how the markers appear as red vertical lines in the Clip Monitor (see yellow highlighted regions in the picture.) You can turn on the display of the marker comments in the timeline too (see Show Marker Comments).

Markers in clip monitor.png


Markers can also be added to clips on the timeline. Right-click the clip and choose Markers -> Add Marker. Markers added this way also appear in the clip in the Project Bin.

Metadata

You expect this to show any meta data that is contained in the clip. Does not appear to work.

Analysis

You can view and delete motion vector data that is associated with the clip from here. This is data created by Auto Mask - Motion Tracking
Kdenlive Clip properties analysis.png
Button 1 Will delete the selected analysis data, Button 2 will allow you to export the data (semi colon delimited text file), Button 3 will allow you to import analysis data.

Generators
Counter

This generates a counter timer clip in various formats which you can put onto the timeline.

Kdenlive Counter dialog.png Previous versions of Kdenlive you could have the background to the counter be transparent. There may be a defect here because it appears the No Background check box does not remove the background from the counter.

Apparently you need a pan and zoom effect to make the font of the countdown smaller

White Noise

This generates a video noise clip — like the "snow" on an out-of-tune analogue TV. In ver 17.04 it generates audio white noise as well as video snow.

Kdenlive Noize generator.png

Color Bars

This generator came in to Kdenlive around ver 17.04. Generates a color test pattern of various types. Including PAL color bars, BBC color bars, EBU color bars, SMPTE color bars, Philips PM5544, FuBK Kdenlive Colour bars.png


This page was last modified on 7 August 2017, at 17:50. Content is available under Creative Commons License SA 4.0 unless otherwise noted.