In kde-4.4, kttsd does not work. When I open system settings, it shows only 3 tabs and the line that says that kttsd is not running.

I tick the box to start it, but the apply button never alights to accept the change. I run it from the command line instead, but nothing happens.

I have also run kttsmngr and it docks into the system tray, but since kttsd is not running/never runs, it cannot do anything, which can be seen when one clicks configure here.

When I open system settings and try to select a talker, none are shown, although I have festival and a number of voices installed. Both festival and espeak work fine from the command line, but in kdeaccessibility, nothing works.

I should say that a number of other users have also reported this problem and the identical symptoms. We are all using fedora kde-4.4.

KTTS and KDE SC 4.4

Just posted a message on fedora's maillist, but it seems that you already have voices installed which I thought was the issue for you. I reinstalled KTTS on KDE SC 4.4 (I'm using Chakra kdemod 4.4) and it worked as it had before in KDE SC 4.3. All of the tabs are still there and it is the same as in the screenshots with KDE SC 4.3. I'm not sure what is wrong for you, but it is most likely a fedora related issue. Have you attempted to build it from source?


No, of course I haven't attempted to build it from source. I use the rpms provided by fedora.

You mention that it had worked in 4.3, but it hadn't been working in fedora since about 2 years ago. I have filed a number of bug reports, including one on (then, it was crashing when one tried to start it; now, it no longer crashes, but kttsd cannot be started and no voices can ever be selected, as the installed voices do not appear in the list), but it still doesn't work.

The last time kttsd worked was in kde-3.5. It has never worked in any version of kde-4.

This page was last edited on 1 March 2010, at 04:43. Content is available under Creative Commons License SA 4.0 unless otherwise noted.