Talk:Lokalize

Jump to: navigation, search

Contents

Thread titleRepliesLast modified
SVN moved to Git417:53, 19 February 2013

SVN moved to Git

So the commands don't work actually. Could you update this? I could not manage to build. Thanks

Vgezer (talk)01:31, 18 February 2013

Can you try again now? I think Neverendingo fixed it.

annew (talk)16:21, 18 February 2013

Yes, tried and the same problem (from line 15 to 18 the same):

CMake Error at CMakeLists.txt:15 (add_subdirectory):

 add_subdirectory not given a binary directory but the given source
 directory
 "/home/volkan/Masaustu/volkan/Masaustu/volkan/Masaustu/volkan/ Belgeler/lokalize/doc"
 is not a subdirectory of
 "/home/volkan/Masaustu/volkan/Masaustu/volkan/Belgeler/lokalize".  When
 specifying an out-of-tree source a binary directory must be explicitly
 specified.

I added those lines into Cmaketxt

 add_subdirectory(/home/volkan/Masaüstü/volkan/Belgeler/lokalize/doc "/home/volkan/Belgeler/lokalize/build/doc")
 add_subdirectory(/home/volkan/Masaüstü/volkan/Belgeler/lokalize/src "/home/volkan/Belgeler/lokalize/build/src")
 add_subdirectory(/home/volkan/Masaüstü/volkan/Belgeler/lokalize/scripts "/home/volkan/Belgeler/lokalize/build/scripts")
 add_subdirectory(/home/volkan/Masaüstü/volkan/Belgeler/lokalize/icons "/home/volkan/Belgeler/lokalize/build/icons")
and now the error msg after make is:

[ 20%] make[2]: *** No target found`/home/volkan/Masaustu/volkan/Masaustu/volkan/ Masaustu/volkan/Masaustu/volkan/Masaustu/volkan/Belgeler/lokalize/build/src/mainwindowadaptor.h to compile, Required by `/home/volkan/Masaustu/volkan/Masaustu/volkan /Masaustu/volkan/Masaustu/volkan/Belgeler/lokalize/build/src/mainwindowadaptor.moc'. Stop.

I am using localized make so, I hope I translated exactly the same strings.

Vgezer (talk)20:04, 18 February 2013

Can you try the new fixed instructions (tested and work here on Mageia) from the beginning?

Thanks in advance for your answer.

Yurchor (talk)17:08, 19 February 2013

The problem was the symlink I used on desktop. Now, I went to the directory /home/volkan/Belgeler/lokalize/build/ typing manually instead of opening the terminal inside the current dir in Dolphin. That was my fault using symlink to the same dir instead of accessing from left side. Symlink was linking to /home/volkan/Masaüstü/volkan/Belgeler/ and caused cmake to create a problem.

Thanks

Vgezer (talk)17:53, 19 February 2013
 
 
 
 

This page was last modified on 18 February 2013, at 16:21. Content is available under Creative Commons License SA 4.0 unless otherwise noted.