KWord/1.5/Manual/Requirements

Jump to: navigation, search

Requirements

In order to successfully use KWord, you need:

  • Qt™ Toolkit 3.2 or later. This can be obtained from Qt Software.
Help-hint.png Tip
While KOffice will compile and run with any version of Qt™ 3.2 or later, it is recommended that you compile and install Qt™ 3.3.4 to take advantage of all the bug fixes (including some security fixes) that have occurred.
  • KDE 3.3.0 libraries (kdelibs) and the KDE 3.3.0 base package (kdebase). These can be obtained from the KDE web page.
Help-hint.png Tip
While KOffice will compile and run with any version of KDE 3.3.0 or later, it is recommended that you compile and install KDE 3.4 to take advantage of all the bug fixes that have occurred.
It is also recommended that you install the arts package 1.3.2 from the KDE FTP site.
  • GNU c++ compiler or any c++ compiler that supports exceptions. For help on obtaining this, please refer to your distribution's web site.
  • autoconf 2.53 or later and automake 1.7 or later
Im-status-message-edit.png Note
In order to use external databases for mail merging documents, you must have the QT toolkit compiled with SQL support. To add SQL support (as a plugin), simply include -plugin-sql-driver in your configure line.

driver should be replaced with mysql, odbc, CVS, or psql as is appropriate for your database needs.


Prev Contents Next
How to Obtain KWord Compile and Install from Source

This page was last modified on 17 August 2012, at 17:05. Content is available under Creative Commons License SA 4.0 unless otherwise noted.