Kdenlive/Manual/Effects

Other languages:
Deutsch • ‎English • ‎dansk • ‎français • ‎Ελληνικά • ‎русский • ‎українська • ‎中文(中国大陆)‎

Effects

Effects in Kdenlive can be used to modify the audio and video properties of the source material.

You add effects to clips by choosing them from the Effects Tab and dragging them onto a clip in the timeline. Or by selecting a clip in the timeline and choosing Add Effect from the Timeline menu or Add Effect from Clip in Timeline right click menu . For more detail see QuickStart - Effects

The effects that are in play on a given clip can be viewed and edited via the Properties Tab that displays when the clip in question is selected in the timeline.

You can also apply effects to an entire track. This is achieved by dragging an effect from the Effect Tab to the Track Header. Or you can click on the track header and chose Add Effect from the Timeline menu . Tracks which have effects added in this fashion will have a gold star icon in the track header.

Figure 1a. Track header showing star icon indicating an effect has been added to this track.


Effects Tab

Make the Effects Tab visible from the View menu (View -> Effects)

Figure 1b - effects tab. The Information icon (6) has been toggled so that the tab displays a brief description of the selected effect at the bottom

The effects tab has 5 different icons that cause the application to show and hide different categories of effects.

By default the effects tab displays the "Main Effects" (Icon 1 selected). These are the Audio Correction, Alpha/Transform, Analysis and data, Colour and the Image adjustment categories.

Icon 2 makes it display all the video effects categories (This option hides the Audio Correction category that is in the "Main Effects" and adds the Misc and Motion categories).

Icon 3 makes it display all the Audio effects categories

Icon 4 is Custom effects

Icon 5 is Favorite Effects. This is the same list that appears in the "Insert an Effect ..." context sensitive menu obtained on a clip in the timeline. An effect gets in this list by choosing Add to Favorites from the context sensitive menu on each of the effects.

Icon 6 toggles the information display which - when on - shows a description of what the effect does.

If you find that you are missing some effects or effects categories that you know and love it is probably because you need to choose to display the hidden effects by choosing an Icon other that Icon 1 - "Main Effects"

To add an effect to a clip, simply drag it from the Effects Tab to the clip on the timeline.

The Properties Tab and its Menu

The Properties Tab

The Properties Tab displays the settings for the effects on the currently selected clip (Figure 3) or the settings for the currently selected transition (Figure 4) depending on whether it is a clip or a transition that is currently selected.

Figure 3 - Properties when a clip with effects is selected
Figure 4 - Properties when a transition is selected

Click the eye icon shown at 2 to temporarily disable the effect and toggle the button to the state shown at 1. Click the empty eye icon shown at 1 to re-enable a disabled effect and toggle the button to the state shown at 2.


Toggle effect on and off.png

To remove an effect from a clip, click the trash can icon labelled 3 in the image below. The arrow labelled 1 minimizes the effect in the Properties Window. And the icon labelled 2 brings up the Properties Tab menu shown.

Kdenlive Effect stack icons2 17.04.png

Reset Effect

This reverts all the settings in the effect back to their default values.

Save Effect

This allows you to save the current effect and all its settings. The saved effect will appear in the Effect List in the Custom category.

Create Group

This creates an Effect Group. An Effect Group is a place holder for multiple effects. You can then save the group of effects — they will the appear in the Effect List, in the Custom Section. You can then later apply the whole group of effects to other parts of the timeline.

To add effects to the group, first add the effect in question to a clip. Then drag that effect and drop it onto the Effect Group in the Properties Tab.

Create Region

New in ver >=0.9.3

The "Create Region" feature enables a user to apply an effect to a part of a clip only. It is a really powerful feature but currently the UI is not fully ready to get its full potential.

Basically, you add an effect to a clip — for example "Sepia" — then you go in the effect's menu and select "Create Region". This will now open a file dialog.

In that dialog, you need to point to an MLT clip with alpha transparency. This is where Kdenlive is not 100% ready because there are many ways we could create such clips, using for example a threshold filter or rotoscoping. But as a start, let's say you can open any image with alpha transparency, or a title clip created with Kdenlive. Then, the "sepia" effect will only be applied on the non-transparent areas of this "region" clip.

Keyframes in effects

Many effects use the concept of "Keyframes". Keyframes are user-defined points in your clip where you want an effect to start, stop or change. You can set the parameters for your effects to different values at different keyframes and Kdenlive will then gradually change the parameters between the two keyframes so that by the time the video has arrived at the next keyframe it will have adjusted the parameter to match that key frame. It interpolates between keyframes.

See QuickStart - Effects for an example on keyframing the RGB adjustment effect.

Since Version 20.08.0

Effect panels get zoom bars. Adjusting keyframes just get easier.


Working with keyframes in the effect stack

Since Version 21.04.0

The effect’s keyframe panel has new icons, improved keyframe grabbing and new functions like:

Move a selected keyframe to cursor
  1. Select the keyframe you want to move
  2. Move the cursor to the position where you want to move the keyframe to
  3. Click on Move selected keyframe to cursor position


  1. Select the keyframe you want to duplicate
  2. Move the cursor to the position where you want to insert the new keyframe
  3. Click on Duplicate selected keyframe


  1. Select all keyframes you want to apply the value on
  2. Go to one of the selected keyframes and change the value(s) as you want
  3. Click on Apply values to selected keyframes
  4. Select the parameters you want to apply and click on OK


Select keyframes with Ctrl + click


Rubber select select keyframes with Shift + click



Exchange keyframes across effects

You can import and export keyframes from/to the clipboard. This feature is not only useful to copy keyframes from one clip to another, it can e.g. also be used to copy the results of the motion tracker to a transform effect.

To export the keyframes the clipboard click on Icon-application-menu.png inside the keyframe widget and choose Copy keyframes to clipboard

Import keyframes dialog

To import keyframes from the clipboard click on Icon-application-menu.png inside the keyframe widget and choose Import keyframes from clipboard. If you have valid data on your clipboard you should see a dialog similar to the screenshot where you can adjust the mapping of the data.

Effect Zones

Since Version 21.04.0

The new Effect Zones allow you to apply effects to specific regions of tracks or the timeline. Zones can be set from the effect zone bar in the timeline or from the interface in the effect panel.

Track Effect Zone

Master Effect Zone


Seek To Active Frame

Some keyframe controls have a seek to active frame button Kdenlive Seek to Active frame button.png (labeled 1 in screenshot A below). When seek to active frame is toggled on and you click on one of the keyframes in the keyframe list, Kdenlive will scroll the preview window to that keyframe. In the example of the screenshot, we have selected the keyframe at 9:20 in A and the clip position caret (highlighted in red box) shows the location of this keyframe. Clicking the keyframe at 10:00 in B shows how the clip position has moved. Kdenlive Seek to active frame.png

Effects Demos

The following three YouTube videos display the results of a number of the video effects available in Kdenlive (Spanish captioning).

Another YouTube video (English Captions).

See also this YouTube play list from Franz M.P.

Effects Categories

See also Effects and Transitions for an alphabetical list of effects and transitions.

The effects are divided into the following categories:

  1. Alpha manipulation
  2. Analysis and Data
  3. Artistic
  4. Audio
  5. Audio channels
  6. Audio Correction
  7. Blur and hide
  8. Color
  9. Color Correction
  10. Crop and transform
  11. Custom
  12. Distort
  13. Enhancement
  14. Fade
  15. Misc
  16. Motion

The available effects are defined by .xml files found in $KDEDIR/share/kde4/apps/kdenlive/effects (e.g. /usr/share/kde4/apps/kdenlive/effects).
Or at /usr/share/kdenlive/effects on version 15.n.

These .xml files contain the default values for the effects parameters. So if you don't like the default values for the effects in Kdenlive, you can modify the defaults by editing these .xml files.

FAQ:

Q: How to duplicate an effect to use similar settings somewhere else?

A: Select your effect in the timeline. In the Properties Tab choose Save (from the Properties Tab Menu). You will now find this effect available in the Effect List Custom section.

A: Other solution: select a strip containing the effect, Copy, then, where you want to apply it again, right-click and select Paste effect instead of Paste.

Q: How to apply an effect on several clips (all) at the same time?

A: You can select multiple clips with Shift + drag (left mouse button) around them. Then right-click and group clips (or Ctrl + G).


This page was last edited on 3 July 2021, at 08:25. Content is available under Creative Commons License SA 4.0 unless otherwise noted.