Sound Problems

Jump to: navigation, search
Other languages:
català • ‎dansk • ‎English • ‎español • ‎français • ‎日本語 • ‎português do Brasil • ‎українська • ‎中文(中国大陆)‎ • ‎中文(台灣)‎

Understanding sound

In order to understand KDE sound, you have to understand Linux sound (this chapter assumes you are running your KDE on Linux). There are two types of sound systems that run on Linux: ALSA and OSS. Both provide their own sound card drivers. ALSA only runs on Linux, OSS runs on many UNIX systems. ALSA allows several applications to access the sound card at the same time, OSS does not. OSS provides a device for sound output. This device can only be accessed by one application at a time. To decrease confusion, ALSA emulates OSS and also provides a device as interface to the sound card. As well ALSA as OSS calls the device for the sound card /dev/dsp usually. PulseAudio, in some distros, provides another layer above these. Its job is to handle multiple streams, so that, for instance, you can receive a message notification at the same time as listening to music.

Usual sound problems are

  • You cannot play sound because you are using an application that tries to access the sound device /dev/dsp, but this device is already in use by another application.
  • You cannot use the system-wide mixer kmix to adjust the volume of an application using the sound device /dev/dsp.
  • Different applications play sound using different devices.

Solutions: There is no silver bullet solving all your sound problems. The solution depends on the application you use to play sound. As an example, you can use mplayer with ALSA and OSS. For more info, see mplayer's documentation by calling

mplayer -ao help

Here are some specific issues that you may meet.

KDE 4 uses the wrong sound device.

That is not an error, but a configuration issue. To tell KDE 4 which soundcard to use (or prefer if available), open System Settings and go to Multimedia in the General tab.

Devices from /etc/asound.conf or ~/.asoundrc are not listed.

Phonon uses a function introduced in ALSA 1.0.14 to find those devices. To make this function list your entry you need to add a name hint. E.g.

hint {
     show on
     description "Name to display for the device"
 }

Here is a complete example that adds a new volume control named Phonon to your mixer:

pcm.softvolPhonon {
     type softvol
     slave.pcm "default:CARD=0"
     control {
         name "Phonon"
         card 0
     }
     min_dB -51.0
     max_dB 0.0
     resolution 100
     hint {
         show on
         description "My Soundcard with extra Volume Control"
     }
 }

After an update, PulseAudio gives you very low volume

PulseAudio has a 'normaliser' function which can cause this. To turn it off, set flat-volumes = no in /etc/pulse/daemon.conf

Low maximum volume with PulseAudio on KDE or pavucontrol shows more than 100% of volume, but KMix goes only up to 100%

Entering the following command

kwriteconfig -file kmixrc -group Global -key VolumeOverdrive -type bool true

and restart KMix, KMix goes to 153% of volume .

This is the same of edit $HOME/.kde/share/config/kmixrc and add:

[Global] 
    VolumeOverdrive=true

References: bug #297959, bug #309597, RHB#704839.

Can't mute event (system) sounds and other KMix strange problems

When KMix show strange bars, etc. or events sound bar doesn't work .

Now with KDE 4.10+, PulseAudio is enabled by user session and we can check that with the following command

ps -ef | grep pulseau

Example of output:

sergio    1880     1  0 12:15 ?        00:04:01 /usr/bin/pulseaudio --start --log-target=syslog

Entering the following commands

killall kmix
rm -rf .pulse/
rm -rf .pulse-cookie 
rm -rf .config/pulse/
kmix

fixed this issue. Old configurations of PulseAudio, can make this issue, if we create a new user, we won't have this issue .


Kde3-button.png

You are using KDE 3 and you keep losing sound. Sometimes it works, sometimes it doesn't.

KDE 3.x uses the aRts sound system. In earlier versions there were a number of problems, but in recent years the only problem remaining seems to be that aRts hangs on to the sound system when it has finished with it. To cure this, use kcontrol -> Sound & Multimedia. Towards the bottom of the General tab there is a setting for Auto-suspend if idle after: Set this to 1 second.

You have multimedia keys but KDE doesn't recognise them

This link has a clear description of what one user did to make his Volume-up and Volume-down keys work.

You tried all of the above but it still doesn't work (Ubuntu variants only)

Try replacing your sound card. If you still don't hear sound, check out this Ubuntu Community page

You want to use an External Sound Card

See the External Sound Card page


This page was last modified on 13 January 2014, at 23:32. Content is available under Creative Commons License SA 4.0 unless otherwise noted.