Kdenlive / Manuel / Démarrage rapide

Jump to: navigation, search
This page is a translated version of the page Kdenlive/Manual/QuickStart and the translation is 71% complete.

Other languages:
dansk • ‎Deutsch • ‎English • ‎español • ‎français • ‎русский • ‎Türkçe • ‎українська • ‎中文(台灣)‎

Quick Start

Creating a new project

Structure de dossier Kdenlive

La première étape est de créer un nouveau dossier (vide) pour notre nouveau projet. Appelons-le tutoriel-mise-en-route/ dans ce tutoriel. Récupérez quelques vidéos échantillons, vous pouvez télécharger celles-ci (7 Mo) [1]. Décompressez-les dans un sous-dossier du projet, par exemple tutoriel-mise-en-route/videos/.

L'image de gauche montre la structure de dossier proposée : chaque projet a son propre dossier, avec des fichiers vidéo dans le sous-dossier videos, des fichiers audio dans le sous-dossier audio, etc. (en savoir plus)

(à partir de maintenant le tutoriel suppose que vous utilisez les échantillons de vidéo fournis, mais il fonctionne avec n'importe quelle autre source.)


Fenêtre de création de projet

Ouvrez Kdenlive et créez un nouveau projet ( Fichier -> Nouveau ).

Choose the previously created project folder (quickstart-tutorial/) and select an appropriate project profile. The video files provided above are 720p, 23.98 fps.[2] If you are using your own files and don’t know which one to use, Kdenlive will suggest an appropriate one when the first clip is added [3] , so you can leave the field on whatever it is.


Adding clips

Arborescence du projet : ajout de clips vidéo

Now that the project is ready, let’s start adding some clips (i.e. the ones you downloaded). This works via the Project Tree widget; a click on the Add Clip icon Icon-add-clip.png directly opens the file dialog, a click on the small arrow shows a list of additional clip types that can be added as well. Video clips, audio clips, images, and other Kdenlive projects can be added via the default Add Clip dialog.


Fenêtre Kdenlive 0.8 avec les fichiers du didacticiel

Après le chargement des clips, Kdenlive va ressembler à ceci. En haut à gauche on retrouve l'arborescence du projet déjà vue. A droite les moniteurs qui affichent les vidéos : le moniteur de clip qui affiche la vidéo des clips originaux, et le moniteur projet avec la vidéo telle qu'elle apparaîtra en sortie, avec tous les effets, transitions etc appliqués. Le troisième élément, également très important, est la ligne de montage (sous les moniteurs) : c'est là que les clips vidéo seront montés. Il y a deux types de pistes différents, vidéo et audio. Les pistes vidéo peuvent contenir n'importe quel type de clip, et les pistes audio aussi... mais lorsqu'on dépose un fichier vidéo sur une piste audio, seul le son sera utilisé.


Enregistrer un projet Kdenlive

Enregistrons le travail via Fichier -> Enregistrer. Notre projet est ainsi sauvegardé, c'est à dire la position des clips sur la ligne de montage, les effets appliqués, et ainsi de suite. Il ne peut pas être ouvert par un autre lecteur multimédia [4]. Le processus de création de la vidéo finale est appelée Rendu.


Timeline

Voir aussi la section Ligne de montage du manuel

Now comes the actual editing. Project clips are combined to the final result on the timeline. They get there by drag and drop: Drag some Napoli (assuming you are using the files provided above, as in the rest of this quick start tutorial; If not, please make sure your screen is waterproof, and perhaps tomatoproof) from the project tree, and drop it onto the first track in the timeline.

First clips in the timeline

Since some cutlery is needed as well, grab the spoon clip and drop it on the first track as well. Then drag the Napoli to the beginning of the timeline (otherwise the rendered video would start with some seconds of plain black), and the Spoon right after the Napoli, such that it looks like in the image on the left. (Where I have zoomed in with Ctrl + Wheel.)


Curseur de montage

Le résultat peut-être déjà prévisualisé en appuyant sur Espace (ou le bouton Lecture dans le moniteur du projet). Vous verrez la soupe directement suivie par la cuillère. Si le curseur de montage n'est pas au début, le moniteur projet va commencer à jouer la vidéo quelque part au milieu ; vous pouvez le déplacer en le faisant glisser sur la graduation de la ligne de montage ou dans le moniteur projet. Si vous préférez les raccourcis clavier, Ctrl+Début donne la même chose pour le moniteur activé (sélectionnez le moniteur projet s'il n'est pas sélectionné avant d'utiliser le raccourci).


Resize marker

Since after eating comes playing, there is a Billiards clip. Add it to the timeline as well. For the first 1.5 seconds nothing happens in the clip, so it should perhaps be cut to avoid the video becoming boring. An easy way[5] for this is to move the timeline cursor to the desired position (i.e. the position where you want to cut the video), then drag the left border of the clip when the resize marker appears. It will snap in at the timeline cursor when you move close enough.


Overlapping clips

To add a transition between eating (the Spoon) and playing billiards, the two clips need to overlap. To be precise: the second clip should be above or below the first one and end some frames after the second one begins. Zooming in until the ticks for single frames appear helps here; it also makes it easy to always have the same transition duration, five frames in this case.

Vous pouvez zoomer en utilisant soit le curseur de zoom au bas de la fenêtre Kdenlive, ou avec Ctrl+molette. Kdenlive zoomera sur le curseur de montage, donc il faut d'abord l'amener à la position que l'on veut agrandir.


Transition marker

Now that the clips overlap, the transition can be added. This is done either by right-clicking on the upper clip and choosing Add Transition or, easier, by clicking the green triangle that appears when you hover the mouse over the lower right corner of the Spoon clip. The latter, by default, adds a dissolve transition, which is in this case the best idea anyway since the Spoon is not required for playing.

The dissolve transitions fades the first clip into the second one. See also Transition section of the manual.


Ajout du dernier clip

Ajoutons maintenant le dernier clip, le piano, appliquons encore une transition en fondu. En l'ajoutant sur la première piste de la ligne de montage, il faut cliquer sur le coin bas gauche du nouveau clip pour ajouter la transition avec le clip précédent.



Effects

Liste des effets

Le piano peut être colorisé en lui appliquant un effet : sélectionner le clip piano, puis double-cliquer sur l'effet Ajustements RVB dans la liste des effets. Si elle n'est pas affichée, vous pouvez l'obtenir via Affichage -> Liste des effet.


Indication de l'effet appliqué sur le montage

Une fois l'effet ajouté, son nom apparaîtra sur le clip dans le montage. Il sera aussi indiqué dans le composant pile des effets.


Pile des effets avec l'ajustement RVB

Pour obtenir une ambiance visuelle jaune-orangé chaleureuse, adapté à la soirée confortable, les composantes bleues doivent être réduites, tandis que rouge et vert doivent être renforcées.

Les valeurs dans le composant d'effet peuvent être modifiées en déplaçant le curseur (le bouton milieu de la souris réinitialise à la valeur par défaut), ou en entrant directement une valeur en double-cliquant sur le nombre à droite du curseur.

Les effets peuvent aussi être ajoutés avec l'icône Ajouter un effet (encadrée dans l'image à gauche) dans la pile d'effets ; il s'applique toujours au clip sélectionné dans le montage. En décochant la case, les effets sont provisoirement désactivés (les réglages sont conservés), cela peut être utile par exemple pour les effets qui nécessitent beaucoup de puissance de calcul, que l'on peut ignorer pendant le montage et rétablir pour le rendu.

Pour certains effets, comme celui utilisé ici, il est possible d'ajouter des images clés. L'icône à chronomètre encadrée signale cette possibilité. Les images clés servent à faire évoluer les paramètres de l'effet avec le temps. Dans notre clip cela permet de faire un dégradé de la couleur du piano depuis celle d'une soirée chaleureuse vers celle d'une nuit froide.


Images clés pour les effets

Après avoir cliqué sur le l'icône image-clé (le chronomètre encadrée dans l'image précédente), le composant de la pile d'effet se ré-organise. Par défaut il y aura deux images-clés, une au début du clip et une à la fin. Déplacez le curseur de montage à la fin du clip, afin que le moniteur de projet affiche les nouvelles couleurs, correspondant aux paramètres modifiés avec l'image clé de la fin.

Vérifiez que la dernière image clé est sélectionnée dans la liste de la pile d'effets ; vous êtes alors prêt à baigner le piano d'une lumière bleue profonde.

Déplacez le curseur de montage au début du projet lancez la lecture (avec espace, ou le bouton lecture dans le moniteur projet), le piano doit alors changer de couleur comme prévu.

L'introduction d'images-clés était la partie la plus difficile de ce didacticiel. Si vous avez réussi à le faire, vous maîtriserez Kdenlive facilement !

See also Effects section of the manual.


Music

Audio fadeout

Since the clips do not provide any audio, let’s search for some nice piece of music, from your local collection or on web pages like Jamendo. The audio clip should, after adding it, be dragged to an audio track on the timeline.

Le clip audio peut être redimensionnée sur la ligne de montage de la même manière que des clips vidéo. Le curseur sera attiré automatiquement à la fin du projet. Pour ajouter un effet de fondu de sortie à la fin du clip audio (sauf si vous avez trouvé un fichier avec exactement la bonne longueur), vous pouvez passer la souris au dessus du coin haut-droit (ou gauche) du clip dans le montage, et faire glisser le disque vert à l'endroit où le fondu doit démarrer (ou terminer)[6].


Rendering

Fenêtre de rendu

Restent quelques minutes, et le projet sera terminé ! Cliquez sur le bouton Rendu (ou allez dans Projet -> Rendu, ou appuyez sur Ctrl+Entrée) pour obtenir la fenêtre présentée ci-contre. Choisissez le nom fichier que vous voulez pour votre nouvelle vidéo avec tous les effets et transitions, choisissez le format MPEG4 (qui fonctionne presque partout) et un débit de 2000k (plus le débit est grand, plus le fichier de sortie est gros, mais la qualité est meilleure - mais comme le débit des clips d'origine était déjà de 2000k, utiliser un débit plus élevé n'améliorerait pas la qualité), et appuyez sur le bouton Rendu dans un fichier.


Progression du rendu

Après quelques secondes le rendu sera fini, et votre premier projet Kdenlive terminé. Félicitations !


References and notes

  1. Si vous préférez Theora (peu probable vu que les vidéos Ogg provoquent souvent des problèmes), vous pouvez également télécharger celles-ci [1]
  2. 720 is the video height, p stands for progressive scan in contrast to interlaced video, and the fps number denotes the number of full frames per second.
  3. Provided Configure Kdenlive Settings under Misc is set to Check if first added clip matches project profile
  4. Pour être exact, il peut être joué avec melt votre_projet.kdenlive, mais ce n'est pas la façon dont vous voulez présenter votre vidéo finale car elle est (probablement) trop lente. En outre, elle ne fonctionne que si melt est installé
  5. Writing it this way suggests that there are several ways of cutting a clip. This is in fact true.
  6. Le disque vert est un raccourci pour ajouter l'effet Fondu -> Fondu sortant ; les deux façons mènent au même résultat

This page was last modified on 8 March 2017, at 09:00. Content is available under Creative Commons License SA 4.0 unless otherwise noted.