Kdenlive/使用手册/快速上手

    From KDE UserBase Wiki
    This page is a translated version of the page Kdenlive/Manual/QuickStart and the translation is 100% complete.

    快速上手

    创建一个新项目

    Kdenlive 的文件夹结构

    要创建新项目,我们首先应新建一个(空的)文件夹。在这篇教程里我把文件夹命名为 quickstart-tutorial/ 。然后去找一些视频剪辑,或者你也可以从这里下载:File:Kdenlive-tutorial-videos-2011-avi.zip (7 MB)[1],然后把它们解压缩到项目文件夹的一个子文件夹中,比如 quickstart-tutorial/Videos/

    左侧的图片展示了建议的文件夹结构:每个项目有自己的文件夹,并且视频文件放在 Videos 子文件夹,音频文件放在 Audio 子文件夹,以此类推的安排其他文件。阅读更多……

    (这个教程假设你使用我们提供的示例视频,但对于其他任何视频也有效。)


    新建项目的对话框

    打开Kdenlive,然后创建一个新项目: 文件 -> 新建

    选择之前创建的项目文件夹(quickstart-tutorial/)并选择一个合适的项目预设。上面提供的视频文件是720p,23.98 fps。[2]如果您使用了自定义文件并且不知道如何选择预设,Kdenlive将在你加入第一段剪辑时向您推荐一个合适的预设[3],所以您可以放心的结束对预设配置的选择。

    如果您乐意的话,可以切换到暗色主题: 设置 -> 颜色主题 i.e Breeze 微风暗色


    添加剪辑

    项目箱:添加视频剪辑

    现在项目的准备工作已经完成,让我们开始加入一些剪辑(例如使用您刚才下载的视频)。这个动作通过项目箱 完成;点击添加素材或文件夹图标就能直接打开文件对话框,点击小箭头可以显示更多的剪辑类型。视频剪辑、音频剪辑、图片以及其他的Kdenlive项目都能通过默认的添加素材或文件夹对话框添加。


    加入了教程文件的Kdenlive窗口

    在加载完素材后,Kdenlive将会像这样显示。左上角部分是目前已知的项目树。它的右侧是用来显示视频的监视器:素材监视器显示原有素材的视频,项目监视器则显示视频的输出效果,包括着所有的特效、过渡以及其他。第三个同样重要的是时间轴(在监视器下方):这里是视频剪辑将会被编辑的地方。时间轴上的轨道分为两种不同类型:视频轨道和音频轨道。视频轨道可以包含任意类型的剪辑,音频轨道也一样——但当您将视频拖放到音频轨道上时,只有它的音频部分被用到。


    保存Kdenlive项目

    现在让我们通过文件 -> 保存来保存我们目前的工作。这将会保存我们的项目,包括我们在时间轴的何处放置了何种剪辑,应用了何种效果,以及其他内容。保存的项目文件是不能 被播放的。[4]得出最终视频的过程被称为渲染


    时间轴

    参考: 时间轴使用手册

    现在来进行真正的编辑。项目剪辑将会在时间轴内被组合成最终的成品。通过拖放即可将它们加入时间轴:先按住项目箱中的Napoli.avi(假设你正使用上面提供的文件,下同),然后将其拖动到时间轴内,松开鼠标,这样它就被加入了。在这里我们把它放在了轨道V2。

    我们的第一次剪辑在时间轴内的显示

    由于我们还需要一些餐具,我们再按住spoon剪辑然后把它拖放到第一条轨道(轨道V2)上面去。然后将napoli拖动到时间轴的最开始(否则渲染出来的视频的前几秒将会是一片黑色),spoon紧跟在napoli后面,如同左边的图所展示的一样。(我已经先通过Ctrl + 滚轮把时间轴放大了一些)


    时间指示线

    按下空格(或者在项目监视器中按下播放按钮)即可预览结果。您将看到napoli之后紧跟着spoon。如果时间指示线不在最开始的话,项目监视器将会在视频中间的某处开始播放;您可以通过拖动来移动它。如果您更喜欢用快捷键的话,Ctrl + Home将会把监视器对应的时间指示线调整至开头。(这里在使用快捷键之前,请确保您已选中项目监视器)


    改变大小时的鼠标指针

    在之前放置的剪辑正常播放之后,我们再来加入billiards。请将其拖入时间轴中(轨道V1)。对于这个剪辑而言,前1.5秒什么也没做,所以我们应该把这1.5秒剪掉 。为了实现这样的操作,一个简单的方法[5]是先把时间指示线移动到我们想要的位置(例如你想要剪切视频的位置),然后把鼠标指针移动到素材的左侧的边缘直到鼠标指针变成像左图那样子。此时拖动鼠标即可达到剪辑的目的。


    部分重叠的剪辑

    为了在餐具(spoon)和billiards之间加入过渡 ,这两个剪辑需要先重叠一部分。准确地说:将第二个剪辑放在第一个剪辑的上方或下方。第一个剪辑应该在第二个开始几帧后再结束。在这里建议放大时间轴直到出现单帧的刻度线,这样就可以轻松指定相同的过渡时间,这里我们设置为5帧。

    您可以通过Kdenlive窗口右下角处的缩放条进行时间轴的缩放,也可以通过Ctrl + 滚轮Kdenlive将会以时间指示线为中心进行时间轴缩放,所以请先将时间指示线调整到你想要仔细观察的部分,然后再进行缩放。


    过渡标记

    现在两个剪辑已经出现了重叠,可以添加过渡了。您可以先右键单击位于上方的剪辑,选择插入合成...再选择擦除,或者,更简单地,将鼠标指针悬停到Spoon剪辑的右下角,直到出现紫色圆圈并且鼠标指针变成“指向”的样子,点击它便会增加一个擦除特效。

    擦除效果会使第一个剪辑渐变至第二个剪辑。参考:Transition section of the manual


    现在让我们来添加最后一个剪辑:Piano,然后再次应用一个擦除效果。如果把它放在时间轴的第一个轨道上(轨道V2),你需要单击新剪辑的左下角来添加擦除效果。



    效果

    效果列表

    通过添加效果 ,Piano可以被上色。首先单击“效果”视图(如果“效果”不可见的话就先激活它:视图 -> 效果),在搜索框输入rgb,然后双击RGB adjustment - RGB调整



    当效果被添加之后,在时间轴上的任意空白区域单击,您便可以看到在剪辑上面显示的效果名称。在选中对应剪辑的情况下,效果也会在效果/合成堆栈中显示。


    加入了RGB调整的效果栈

    为了给视频添加橙黄色的色调(合乎夜间使用电脑的护眼颜色),我们需要适度增强红色和绿色并削弱蓝色。

    效果/合成堆栈中的各种值可以通过滚动条来调节(按下鼠标中键即可将其重置为默认值),也可以通过双击编辑滚动条右侧的数字,直接编辑对应的值。

    效果/合成堆栈总是指向已选中剪辑。每个效果可以通过点击眼睛图标来隐藏,点击效果/合成堆栈顶端的眼睛图标可以隐藏所有的效果。(不必担心,你添加的效果不会被删除的)隐藏效果相当有用,例如对于那些十分消耗计算机资源的效果,可以在编辑时将其隐藏,渲染时再恢复显示。

    对于某些效果(例如此处使用的),可以为其添加关键帧。如果某个效果可以添加关键帧的话,在眼睛图标的左侧应该会有一个手表图标。关键帧是用来实现随着时间变化改变效果的参数的。在本例中,我们可以通过关键帧达到暖色调渐变为冷色调的效果。


    效果关键帧

    在点击启用关键帧 图标 (前面提到的钟表图标)之后,属性窗口会刷新(译注:这部分似乎不符合当前版本情况)。默认会产生两个关键帧,一个在剪辑开头,另一个在剪辑末尾。将游标拖动到时间轴的末尾,这样在我们调节位于末尾的关键帧参数时项目监视器就会显示出新的颜色。

    确保你在编辑参数值时选中了相应关键帧。然后让我们把Piano调整成深蓝色。

    把游标拖动到时间轴开头然后播放(按空格,或者项目监视器里面的播放按钮),Piano应该会如我们预想中那样慢慢改变颜色。

    关键帧是这篇教程中最难的一部分!如果你学会了怎么去使用它,你很快就能轻松玩转Kdenlive了!

    参考 Effects section of the manual


    音乐

    音频淡出

    由于剪辑本身不包含任何声音,我们最好搜集一些不错的音乐,从您自己的本地文件或者网上搜集。音频文件在导入到项目中之后,应该添加到时间轴上的音频轨道中。

    音频剪辑可以像视频剪辑一样在时间轴上调整长短。调整长度时,光标将在项目结束的地方自动对齐。如果您要在音频剪辑的末尾添加淡出效果(除非您找到长度正好合适的文件),您可以将鼠标悬停在时间轴中的剪辑的右上角(或左)边缘并将红色阴影三角形拖动到淡出开始的位置。[6]


    渲染

    导出对话框

    过了不久,我们的项目已经完成了!点击工具栏上的导出按钮(或者项目 -> 导出,也可以直接按快捷键Ctrl + Enter)来调出如同左图那样的对话框。为包含所有效果和过渡的新视频选择所需的输出文件,选择 MP4格式(几乎适用于所有地方),选择输出文件位置并按下 导出为文件 按钮。


    导出过程

    过了一会之后,导出完成了,您的第一个Kdenlive工程也大功告成了。祝贺!


    完整的教程

    关于当前版本 Kdenlive 的更多文档可以从 完整使用手册 中找到。

    注解

    1. 如果你更喜欢Theora编码方式的视频的话(你可能不会喜欢,因为Ogg Video容易出问题),你也可以选择下载这个:kdenlive-tutorial-videos-2011-ogv.tar.bz2
    2. 720是视频的高度,p则代表逐行扫描,与隔行扫描相对应。fps数表示每秒钟内的完整帧数。
    3. 配置Kdenlive杂项中,检查第一个添加的剪辑是否与项目配置文件匹配 被默认打开。
    4. 为确保严谨,kdenlive项目文件其实是可以 被播放的,通过命令melt yourproject.kdenlive,但这并不是您想要的最终结果,因为他(很可能)特别的慢。另外,这条命令只会在melt已经安装的情况下正常工作。
    5. 用这样的语句是为了表示剪切素材有好几种方法。确实如此。
    6. 这个阴影三角形是添加效果淡出的简便方式。两种方式达到的效果完全一致。