Problems with FuzzyBot handling of translations

Marked for translation but not appearing in Special:LanguageStats

Note: There are probably many more pages with this problem

  • Pages where the date of marking for translation is not known
    • Plasma/Tasks - has been updated after translations were added, but has problems*

Pages recently marked for translations again

New pages marked for translation

Eksperimenting

It is odd that some pages are picked up by the translate system while others are not. I am going to experiment a bit to see if I can come up with an answer to why that is and possibly find a work-around in the process.

21/7 2020: One theory is that when someone works on the translations of a page it will be picked up. I marked KDE Connect/Tutorials/Useful commands up for translation after a new section had been added and then immediately went on to translate it. Prior to the new section the page had been translated to ‎català, ‎français, ‎português do Brasil, and українська, all fully translated. Checking Special:LanguageStats for these languages shows the new unit added to the translate system and the translated versions of the pages are now shown to be 90% translated. It seems that this works.

21/7 2020: Modified unit 6 on Kdenlive, marked for translation and opened translation page, but without translating the unit. In stead I just "retranslated" an old unit (adding a character, removing it again and saving the unit). This to see if the page shows up in Special:LanguageStats with the modified unit having been marked as such.

24/7 2020: Marked Juk for translation - 3 new units were added. The page appeared immediately in LanguageStats, and the new units were displayed as untranslated; however entering translations failed with this message:

This namespace is reserved for content page translations. The page you are trying to edit does not seem to correspond any page marked for translation.

Maybe fuzzybot still needs to process the page even though it appears in LanguageStats?

Kdenlive still does not appear in LanguageStats, and the modified unit is not marked as needing an update. Waiting for fuzzybot?

25/7 2020: Marked KDE Connect/Tutorials/Useful commands (modified unit 9, and 15) and KBibTeX/Development‎ (modified units 69, 73, 10, and 11).

28/7 2020: Marked Marble/Tracking - just one modified unit. Page does not appear in LanguageStats and opening the translation page for this page shows no outdated units.

As of today no page in this "experiment" has been updated.

1/8 2020: Marked KDiskFree (both modified and new units) and Plasma/Kickoff (new unit)

5/8 2020: Marked Plan (modified unit)

Problems with some pages

As of june 2020, some pages have been incorrectly handled by the translation system. They are marked by an * in the list above. Note: Not all pages have been checked for this problem!

The problem is this: There are units, which have previously been translated and which do not show up in the list of outdated units. Also, they are not flagged in the list of all units. However, when these units are opened, a message appears saying that the unit may need to be updated. In some cases this is clearly not the case - nothing has changed in the English text; but in some cases significant changes have been made to the unit, and it should have been listed in outdated units.

To make things worse, when you click Show differences in the message, the original text of the entire page is shown rather than just the text of the actual unit, which means that the only way to determine whether such a unit has changed is to compare the English text with the existing translation.

Note: This should only affect those languages that had translations of a page prior to its being marked for translation again.

More pages with this problem


This page was last edited on 6 August 2020, at 07:13. Content is available under Creative Commons License SA 4.0 unless otherwise noted.